Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Engine "racing" at 2k RPM


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
flyfishboston
Member


Joined: 09 Apr 2004
Location: North Easton, Mass.

PostPosted: Mon Apr 12, 2004 5:25 am    Post subject: Engine "racing" at 2k RPM Reply with quote

Well... I really don't quite know how better to pose the question, so here's my problem.

(1998 5.2L) I'll be driving on the hi-way at about 70mph (cruise control is not on) and will hit a seam or small pot hole in the road and the tach will jump a few hundred RPM then return to 2K. (Note, I've heard of a simular condition where the transmission is hunting for gears, but not so in this case, the transmission is fine). Now this is what mystifys me the most... when I am accelerating at the same speed, and hit the same seam or pothole, all is well.

Anyone have this problem?

I've replaced the IAT and cleaned the port and TB... could it be the TPS?
Back to top
View user's profile Send private message Send e-mail
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Mon Apr 12, 2004 9:01 am    Post subject: Reply with quote

It could be the TPS.. But I would think maybe check the Crank Position sensor.. .IT could be loose or something that may account for the sudden surges but it wouldnt explain why it doesnt do it while accelerating in the same spot... That is quite a problem you havethere... YOu are absolutly sure its not tranny related??

It Just seems like a weird engine prob. But with electronic engines it could be any sensor..
I had a problem where If I turned to the right all my lights would dim..
Then come back on .. Then if you hit the brakes hard same thing..

Turned out to be a bad battery ground...

Took me a week to find a 30 second fix..

Good luck with yours..

Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
hrjaw
Member


Joined: 25 Mar 2004
Location: The Ocean State

PostPosted: Tue Apr 13, 2004 6:46 am    Post subject: Reply with quote

I am actually having somewhat of a similiar problem with my 99 WJ 4.0. all of a sudden it has decided to race at 1500 rpm's, but only when in nuetral or park. i recently jsut changed the plugs, and put in platinums, so not sure if it would be as simple as a plug problem. and it does not always do it. it comes and goes, and is driving me nuts. i checked and re-checked all hoses to make sure it was not a vacuum leak, adn at this point am dumb founded.
Roger
_________________
H.R. Jawharjian
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group