Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

airbag light came on ,and gauges stopped working?


 
Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message
illumin8em
Member


Joined: 29 Jan 2004
Location: West virginia

PostPosted: Mon Apr 19, 2004 7:05 pm    Post subject: airbag light came on ,and gauges stopped working? Reply with quote

airbag light came on, and gauge stopped woking today when I hit a bump, then came back on. Now they go back and forth when it's bumpy. Any suggestions?
_________________
black 98 TJ
R.E. sf 3.5" 33"x12.5" MTRs 4.56 gears, all in boxes
Back to top
View user's profile Send private message
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Mon Apr 19, 2004 7:13 pm    Post subject: Re: airbag light came on ,and gauges stopped working? Reply with quote

illumin8em wrote:
airbag light came on, and gauge stopped woking today when I hit a bump, then came back on. Now they go back and forth when it's bumpy. Any suggestions?


Sounds like you've got a loose contact or wire somewhere...possibly a bad ground. I'd have to check the wiring diagrams to figure out exactly what would cause it (I'm at work now).

If there's no response before then, I'll check in the morning when I get home.

Steve
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
ehirner
Moderator
Moderator


Joined: 01 Jan 2004
Location: Eastern PA

PostPosted: Mon Apr 19, 2004 7:31 pm    Post subject: Reply with quote

This used to happen in my 97 fairly frequently and occurred 3x in the 99 recently. Basically, the long term solution is to uninstall your gauge cluster, slightly bend the tabs a bit to maintain better contact, then reinstall the cluster. That's the labor "intensive" solution as there's a bunch of bolts and plastic panel pieces to remove in order to do it. But it's not difficult.

The short term quick solution, smack the top of the cluster with your hand. Everything should pop right back up until it acts up next time.
_________________
04 Unlimited
Back to top
View user's profile Send private message AIM Address
Upstate Chili
Member


Joined: 24 Apr 2004

PostPosted: Sat Apr 24, 2004 2:26 pm    Post subject: Reply with quote

Here's a write-up

http://www.jeepmadness.com/guages.htm
Back to top
View user's profile Send private message
marco
Member


Joined: 15 May 2004

PostPosted: Sat May 15, 2004 4:30 am    Post subject: Reply with quote

It's happening the same to my TJ 97.
Does not need a bump, just randomly the gauges go on and off (mostly off) and airbag light is on.
Did you find any solution?
My service shop is getting crazy...already swapped the complete instruments (tacho, speed....everything) with another TJ. Mine works on that but the other has the same problem on mine!

No speed and no rpm too.

Please help me!

Thanks
Back to top
View user's profile Send private message
ehirner
Moderator
Moderator


Joined: 01 Jan 2004
Location: Eastern PA

PostPosted: Sat May 15, 2004 5:35 pm    Post subject: Reply with quote

marco wrote:
It's happening the same to my TJ 97.
Does not need a bump, just randomly the gauges go on and off (mostly off) and airbag light is on.
Did you find any solution?
My service shop is getting crazy...already swapped the complete instruments (tacho, speed....everything) with another TJ. Mine works on that but the other has the same problem on mine!

No speed and no rpm too.

Please help me!

Thanks

Marco, first...I deleted your thread since no one had responded to it and you found this thread that deals with the same problem.

Have you tried what I suggested above? I know you said you swapped clusters, but if it's a problem with the connector not making adequate contact, I don't believe a different cluster would fix the problem. Try just slightly bending the tab in the connected so they fit tighter in the connector on the cluster. This fixed mine.
_________________
04 Unlimited
Back to top
View user's profile Send private message AIM Address
macb
Member


Joined: 01 Feb 2004
Location: San Antonio, TX

PostPosted: Sun May 23, 2004 7:04 pm    Post subject: Reply with quote

follow the link to the write-up...this has fixed several jeeps. The problem is more common than you would think.
_________________
The difference between Genius and Stupidity?
Genius has limits...
H2 Recovery Team and NO BLING Gear!

Back to top
View user's profile Send private message Visit poster's website
marco
Member


Joined: 15 May 2004

PostPosted: Mon May 24, 2004 4:22 am    Post subject: Reply with quote

that link just take me to a site selling stickers....
Back to top
View user's profile Send private message
el_dubya
Member


Joined: 20 Sep 2005

PostPosted: Thu Aug 02, 2007 7:49 am    Post subject: Reply with quote

when I try the jeepmadness link it takes me to some search thingy madoo. Anybody have a new link or could post what the writeup was?
_________________
Dub

'98 TJ SE
15x7 ProComp Series 51 Rock Crawler Wheels
31x10.50 General Grabber AT2's
Taurus Fan
Uniden PC68 Elite CB
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group