Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

new member please help

Goto page 1, 2  Next
 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
01limited
Member


Joined: 26 Oct 2004

PostPosted: Tue Oct 26, 2004 7:03 pm    Post subject: new member please help Reply with quote

hi, my name is jim and i hope you can help?? i have a 2001 grand cherokee ltd 4.7 v-8. with 44,000 miles. here's the problem my truck was having a hard start problem when it's cooled down like the fuel pressure was bleeding off so i took it to my friend's shop and he checked my fuel pressure and we started the truck shut it down and it went from 50 psi to 30 psi within 30 sec -45 sec. so we changed the fuel pump fuel filter i read there was a tsb on this and my other friend who works for jeep said all the fuel pumps were upgraded to fix the problem they were having. anyway all was good for two days now the same thing is happing when it's cold sometimes it will start up sometimes i have to mash the gas pedal and sometimes that takes 2 or 3 times before it starts. if i turn the key on then off to prime it that works sometimes. what is the problem leaky injectors??? is there a way to test without ripping the motor apart?? what else can be causing this Sad
Back to top
View user's profile Send private message
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Tue Oct 26, 2004 8:24 pm    Post subject: Reply with quote

I will do some research and let you know what I find...

Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
01limited
Member


Joined: 26 Oct 2004

PostPosted: Tue Oct 26, 2004 8:59 pm    Post subject: Reply with quote

hi, carl thank you
Back to top
View user's profile Send private message
01limited
Member


Joined: 26 Oct 2004

PostPosted: Wed Oct 27, 2004 1:54 pm    Post subject: Reply with quote

guys can this be a crank senser problem????????
Back to top
View user's profile Send private message
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Wed Oct 27, 2004 6:35 pm    Post subject: Reply with quote

Havent found anything relevent yet .. .But I havent given up...

As far as CPS goes.. Normally when it goes out you just cant start your ride ...
Period. No matter what you do ... It could be dirty maybe and causing an intermittent problem but its definatly not bad..

Pull it out and clean it... Its on the drivers side near the firewall you can reach it from the top usually...
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
Buddha_Kip
Member


Joined: 03 Jan 2004
Location: New Orleans, LA

PostPosted: Wed Oct 27, 2004 9:18 pm    Post subject: Reply with quote

you can guinnea pig mine, Carl...it does the same thing from time to time, but not often enough to bother with it.

Actually, I must say you can guinnea pig it as soon as I get it back from the dealer....that's right, it goes back in tomorrow...the passenger-side front floor is continually a lake, and tonight the passenger-front window motor broke and the window dropped down into the door...had to take off the panel to get it back (FUN FUN)
_________________
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Thu Oct 28, 2004 2:47 pm    Post subject: Reply with quote

Classic.. That thing must have a reserved spot in the dealers lot... rofl

Give me a call when you get it out ..

Or you can call anytime...
By the way.. There is a lot near my house with about 6 ZJ's and a few XJ's on it.. Still looking for trail rig????Mr. Green
Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
majikxms
Moderator
Moderator


Joined: 18 Feb 2004

PostPosted: Thu Oct 28, 2004 3:27 pm    Post subject: Reply with quote

Buddha_Kip wrote:
and tonight the passenger-front window motor broke and the window dropped down into the door...had to take off the panel to get it back (FUN FUN)


Are we seeing a trend here pull hair The count is up to at least 7 Jeeps that had this problem, on this board alone.
Back to top
View user's profile Send private message
01limited
Member


Joined: 26 Oct 2004

PostPosted: Fri Oct 29, 2004 12:26 pm    Post subject: Reply with quote

okay my jeep is starting up cold every morning, now when i'm inbetween hot and cold meaning if i take the jeep for a ride and let it sit for a 1hour it will have a hard start cranking problem. tested fuel pressure again and it starts off at 50psi then drops down to 25 in 15mins it get pressure as soon as the key is turned in the on position. now where do i go???
Back to top
View user's profile Send private message
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Fri Oct 29, 2004 1:42 pm    Post subject: Reply with quote

Now that sounds like something the Idle air control might do.. Its on the back of the Throttle body.. Mine used to do something similar..
It would run fine for about 10 mins. Then stall out and it would be hard to start but once it got started again it would run fine .. Its like it was having trouble transitioning from cold to normal running temp.. When it warmed up and the choke clicked off it wouldnt start for a few minutes.. Then when It started it would be fine.. Its was crazy as hell.. Anyway.. Turned out to be Idle air control.. Sounds kinda like what your problem... Might be worth a try..

Did you try pulling the codes?? Here is how...

Retrieving codes:

Turn the ignition key until the digital odometer displays, repeat three times in succession and then back to "On" (On/Off, On/Off, On/Off, On). At the fourth "On" the odometer will be replaced with codes. If no codes are present then "Done" will appear.

Erasing codes:

After three good trips the MIL is extinguished and the Task Manager automatically switches the trip counter to a warm-up cycle counter. DTCs are automatically erased following 40 warm-up cycles if the component does not fail again.

DTCs can be erased anytime with a DRB III. Erasing the DTC with the DRB III erases all OBD II information. The DRB III automatically displays a warning that erasing the DTC will also erase all OBD II monitor data. This includes all counter information for warm-up cycles, trips and Freeze Frame.
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
01limited
Member


Joined: 26 Oct 2004

PostPosted: Fri Oct 29, 2004 1:54 pm    Post subject: Reply with quote

just bought iac valve. and there are no codes. i think this problem is going to be a tuffy.
Back to top
View user's profile Send private message
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Fri Oct 29, 2004 2:43 pm    Post subject: Reply with quote

The crank sensor normally controls the timing (spark), the cam sensor normally controls injector timing. Just another thing to check. Is the 4.7 a DOHC engine?, If it is it might not be that way though.
Back to top
View user's profile Send private message Send e-mail
01limited
Member


Joined: 26 Oct 2004

PostPosted: Fri Oct 29, 2004 3:14 pm    Post subject: Reply with quote

hi, it's the 4.7 NOT the ho motor.
Back to top
View user's profile Send private message
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Fri Oct 29, 2004 6:49 pm    Post subject: Reply with quote

I meant DOHC as in double overhead cam.
Back to top
View user's profile Send private message Send e-mail
01limited
Member


Joined: 26 Oct 2004

PostPosted: Fri Oct 29, 2004 7:14 pm    Post subject: Reply with quote

no i don't have that
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group