Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Fan Belt


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
Icewind
Member


Joined: 23 Oct 2004

PostPosted: Sat Nov 13, 2004 6:59 pm    Post subject: Fan Belt Reply with quote

When I turn on my car after it has been in the cold for a little while and push on the gas the fan belt will sqeak fairly loud for a couple seconds. And also if it is not squeaking, once I turn on my heater it will start to do it.

Any reason why this could be? I just replaced my water pump, did I maybe tighten to fan belt too much?

It is an 89 cherokee pioneer.
Back to top
View user's profile Send private message
935speedxj
Member


Joined: 08 Oct 2004
Location: pittsburgh pa

PostPosted: Mon Nov 15, 2004 8:16 pm    Post subject: Re: Fan Belt Reply with quote

Icewind wrote:
When I turn on my car after it has been in the cold for a little while and push on the gas the fan belt will sqeak fairly loud for a couple seconds. And also if it is not squeaking, once I turn on my heater it will start to do it.

Any reason why this could be? I just replaced my water pump, did I maybe tighten to fan belt too much?

It is an 89 cherokee pioneer.
you might have oil on your belt or it may be a bit loose ect try there
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Icewind
Member


Joined: 23 Oct 2004

PostPosted: Mon Nov 15, 2004 9:24 pm    Post subject: Reply with quote

Ok I will check that. I thought I got it tight enough but maybe not. I put some wd40 on it when it does it but that does not seem to last very long.
Back to top
View user's profile Send private message
CoreyXJ
Turkish
Turkish


Joined: 20 Jan 2004
Location: Louisville, KY

PostPosted: Tue Nov 16, 2004 10:08 am    Post subject: Reply with quote

I know this sounds stupid but you might want to check and make sure that it is even your fan belt doing the squeaking. Sometimes as the AC clutches get older they will squeak for a second right on start up. If it is the belt then I would probably replace the serpentine belt instead of spraying all that dressing crap all over it.

Good luck - CoreyXJ
_________________
"Get busy living, or get busy dying..." - C.W.

"Do what you love to do...the money will eventually follow" - I. Larry
Back to top
View user's profile Send private message Visit poster's website
acrid
Member


Joined: 02 Jan 2005
Location: PDX, OREGON

PostPosted: Wed Jan 05, 2005 3:05 am    Post subject: Reply with quote

i know this is an old post but if anyone doesn't already know, you're never supposed to use belt dressing on any serpintine belt in any car.
hilift
_________________
'94 xj 4d w- '97 4.0HO 5 speed ax15 dana 30 c8.25 ar767 15's 31" bfg MT's TBS 1", 62mm TB K&N cone flwmstr exhaust. 5" homebrew 1/2 rusty's (f) 1/2 dakota packs (r) 2d shim 2" tranny drop wilderness r-rack full spare hi-jack
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group