Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

BIG problem with my 93 5.2L


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
beanplant
Member


Joined: 25 Nov 2004

PostPosted: Thu Nov 25, 2004 12:03 am    Post subject: BIG problem with my 93 5.2L Reply with quote

Well first off, Happy Thanksgiving to all of you. Mine's not starting off so great.
Some backround:
On my way home from my girlfriend's tonight, I was on the highway, and i felt my car start to shutter a little..... then it kept getting stronger.... almost like it was low on gas (I have more than a 1/4 tank). Then the RPMs kept going down. It finally died. I pulled over and tried starting it back up. Took a couple times, then it started.
It died a few more times, so I drove all the way home on the shoulder. It has a VERY rough idle now, and if you give it any gas it stalls, and wants to die. But if you get it up above about 1200-1500 RPMs it seems like It'll stay. I can let it sit at 2000-3000 RPM without any problem. it just wont idle, or do anything when you give it any throttle. It keeps dieing.
What could this be?!?!?! Fuel pump, fuel filter, plugs, wires, cap, rotor, throttle position sensor????
If ANYONE can help, it would be GREAT because its snowy up here any my stang doesn't do too well in the snow. I need my 4WD.

Thanks guys!
-Shaun
_________________
1993 Grand Cherokee 5.2L 4X4
Back to top
View user's profile Send private message AIM Address
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Thu Nov 25, 2004 12:30 am    Post subject: Reply with quote

OK... Look at the passenger side of your engine .. Right in front of the fuel rail.. You will see a sensor screwed into the intake..
AIR CHARGE TEMP SENSOR... Pull it out.. If its dirty go buy a new one..
Bring it with you.. So you can match it up...


Oh yeah.. Buy the one for the 93 Dodge truck with the 5.2 its about $19.99

The same part for a Grand Cherokee is much more expensive...
(I think it was $70 bucks or something stupid..)
Its the exact same part but one is Chrysler (Jeep) and one is dodge..
SO the part number is different..

I had the exact same problem except that you didnt say that your gas mileage went to crap while it was doing that.. I think I was getting about 4 miles a gallon when mine did it.. It fan fine when I either reved the engine or was going hiway speed but like I said it ran fine at highway speed but left a black cloud of unburned gas behind me and I could go about 60 miles on a tank of gas... Mr. Green

Check that sensor and let me know.. I will check this in the AM ..
Good luck..

Carl


Oh lookie here ..
This is the sensor I am talking about...

_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
beanplant
Member


Joined: 25 Nov 2004

PostPosted: Thu Nov 25, 2004 8:58 am    Post subject: Reply with quote

Okay, I'll definitely check that sensor. The thing is, I don't know what my gas mileage because I can't get the Jeep to get up to that speed. I was talking free- revving. This morning I can't even get it to start. I CAN hear the whirring sound of the fuel pump when the key is 'on'. But not when the engine is running. Maybe I'm jsut hard of hearing. I haven't put heet in my gas for a while, it could be that too.

If anyone has ANYTHING else, I would GREATLY appreciate it. Thanks!

-Shaun
_________________
1993 Grand Cherokee 5.2L 4X4
Back to top
View user's profile Send private message AIM Address
beanplant
Member


Joined: 25 Nov 2004

PostPosted: Thu Nov 25, 2004 9:24 am    Post subject: Reply with quote

Checked it. It was filthy. I can't buy another one today because all the parts stores are closed. I cleaned it. And my car still won't start. It just cranks.... a lot. I don't want to kill my starter so I stopped. Now just just seems like its not sparking?

Anyway, was this a normal thing to happen in the middle of driving down the highway?

-Shaun
_________________
1993 Grand Cherokee 5.2L 4X4
Back to top
View user's profile Send private message AIM Address
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Thu Nov 25, 2004 9:43 am    Post subject: Reply with quote

Thats how mine happened.. I was on my way to go wheeling .. And all of a sudden my truck was running like crap..

I wish someone had told me. I bought a new Map sensor and a new TPS and a new Idle control and was checking on the price of a new ECU.. When I decided to pull that sensor..

$200 buck later I fixed it with a $20 part.. Rolling Eyes

IF you cleaned it and it wont start at all its probobly trashed.
I would almost gaurantee that is your problem..

Let me know tommorow .. Mr. Green

Good luck..
Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
beanplant
Member


Joined: 25 Nov 2004

PostPosted: Thu Nov 25, 2004 9:49 am    Post subject: Reply with quote

Sweet, I can only hope. Thanks a TON man!

Another thing. If this sensor was bad, would it make my car NOT start at all?

-Shaun
_________________
1993 Grand Cherokee 5.2L 4X4
Back to top
View user's profile Send private message AIM Address
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Thu Nov 25, 2004 12:21 pm    Post subject: Reply with quote

IT did when I tried the same thing.. I took it out and cleaned it and then it wouldnt start at all cause the computer relies on that signal to run.. I just figured that when it was dirty it got at least some signal but I probobly broke it when cleaning and it got none.. Maybe you did the same..

Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
beanplant
Member


Joined: 25 Nov 2004

PostPosted: Fri Nov 26, 2004 7:10 am    Post subject: Reply with quote

Nope, didn't work at all. Now I'm pissed. Not at you, but at my car. It could be about a hundred different other things now. Ignition, fuel pump, sensors..... GAAAAAHHHHH this F'in sucks. This is the crap that makes you want to sell the SOB
_________________
1993 Grand Cherokee 5.2L 4X4
Back to top
View user's profile Send private message AIM Address
93ZJ
Member


Joined: 13 Oct 2004
Location: Maine

PostPosted: Thu Dec 02, 2004 5:28 pm    Post subject: Reply with quote

hey did your service engine soon light come on? If it did then u can get a scan tool and read it, it should be able to tell u all u need too know.
Back to top
View user's profile Send private message Yahoo Messenger
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Thu Dec 02, 2004 5:48 pm    Post subject: Reply with quote

You can take off the fuel filter and tap it on your work bench if crud comes out ...Change it...

Go to auto parts store and rent /buy a fuel pressure tester and check it...

You should have about 39 pounds or so.. IF you have more than 45 the fuel pressure regulator could be bad ... If you have less than 39 or none at all your fuel pump could be the culprit...

IF your fuel pressure is good ... Mark that off the list.. Neutral

TPS ...Its on the drivers side of the throttle body..

you can check voltage to it.. You should have between 5-9 volts there..

YOu can pop out the idle air control valve..(Back of throttle body) if its clogged with carbon.. Get some throttle body cleaner and clean it up good.

It wouldnt hurt to go ahead and do a good tune up...
Fuel filter , Rotor , cap and wires... (the cap is a bitch to get out of there.) You need to mark the wires and pull them off.. Then remove them..
Pull the cap off.. replace the rotor and put the new cap on .. Then put the wires back on..

I guess you should start by doing a good tune up... Then make sure you are getting a good spark..(I have thrashed quite a few coils.....Accell coils do not handle off road conditions well.. ) I actually have a stock coil in place and on my rig and I run a MSD coil now... but if it goes out I can swap back to stock in about 2 minutes...

Once you know you have good spark and the wires and everything are good .. Then you can change the fuel filter ...

Then if it still wont start.. Do like I said and check fuel pressure..

Hopefully this will give you at least a good order to check things ..With minimum spending..

No real wasted money on parts if all you do is a good tune up.. (And you can keep your stock cap , rotor, and such as spares...

Let us know what happens next or if you have a check engine light..
What code its flashing..

IF you dont know how to check for codes I can tell you that to... Its very simple..

Good luck. and let us know...


Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
beanplant
Member


Joined: 25 Nov 2004

PostPosted: Thu Dec 02, 2004 8:44 pm    Post subject: Reply with quote

Finally fixexd it last week after 3 days. It ended up being my ignition coil, cap, and rotor. I still had spark, just apparently not strong enough. Oh well, she runs purty good now. Thanks guys


-Shaun
_________________
1993 Grand Cherokee 5.2L 4X4
Back to top
View user's profile Send private message AIM Address
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Fri Dec 03, 2004 11:55 am    Post subject: Reply with quote

Glad you didnt give up...

Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group