Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Another problem..?


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
copey
Member


Joined: 01 Oct 2004
Location: Tamworth Staffs..UK

PostPosted: Tue Oct 12, 2004 11:48 am    Post subject: Another problem..? Reply with quote

Just noticed that my Oil Pressure gauge needle seems to fluctuate as I drive along at a steady speed,not by a great deal but is that normal,other vehicles i`ve had ,have just had a warning light that comes on (normally to late) if there is a problem.... Smile
Back to top
View user's profile Send private message Send e-mail Visit poster's website
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Tue Oct 12, 2004 4:46 pm    Post subject: Reply with quote

Mine does that when I am low on oil..

Have you checked???

Seems silly but thats what mine does. Mr. Green Mr. Green
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
copey
Member


Joined: 01 Oct 2004
Location: Tamworth Staffs..UK

PostPosted: Tue Oct 12, 2004 11:14 pm    Post subject: Reply with quote

Yes have checked...spot on the mark.. Very Happy
_________________
My first Jeep.. but not my last...
Back to top
View user's profile Send private message Send e-mail Visit poster's website
MaineZJ
Member


Joined: 09 Jan 2004
Location: Maine

PostPosted: Wed Oct 13, 2004 4:34 am    Post subject: Reply with quote

loose sending unit?
_________________
93 ZJ
5.2 - 46RH - 249- 4.5" RE coils
Back to top
View user's profile Send private message AIM Address
copey
Member


Joined: 01 Oct 2004
Location: Tamworth Staffs..UK

PostPosted: Thu Oct 14, 2004 1:42 pm    Post subject: Reply with quote

Quote:
loose sending unit?


Just going thro all the connections ,haven`t found a problem yet..thanks for your input..all gratefully received...... Very Happy
_________________
My first Jeep.. but not my last...
Back to top
View user's profile Send private message Send e-mail Visit poster's website
jonathan
Member


Joined: 06 Jan 2005
Location: Virginia Beach

PostPosted: Tue Jan 11, 2005 4:51 pm    Post subject: oil pressure Reply with quote

Rolling Eyes
I had the same problem a while ago. Turn's out the Oil pick up tube was loose. Due to debree on the intake screen. Sometimes a clogged oil filter will cause the same problem.
Back to top
View user's profile Send private message MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group