Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

power surge


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
raelayotte
Member


Joined: 22 Jun 2005
Location: MIchigan

PostPosted: Wed Jun 22, 2005 4:59 am    Post subject: power surge Reply with quote

ok i need help i have a 98 xj i just replaced the cap roder and plugs it did not help i have a power surge at about 40 to 60 i have cheaked all the vac lines good
PLEASE HELP
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Wed Jun 22, 2005 5:12 am    Post subject: Reply with quote

try changing the fuel filter. And have you checked the air filter?
_________________
06 Rubicon
4" RC sus. lift, 1" PA BL
Warn rear bumper/carrier, Xenon flat fender flares, Warn 9.5Ti winch
PICS
Back to top
View user's profile Send private message Send e-mail
raelayotte
Member


Joined: 22 Jun 2005
Location: MIchigan

PostPosted: Wed Jun 22, 2005 8:24 am    Post subject: Reply with quote

there is no fuel filter on the 98 and i have a k/n air filter
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Wed Jun 22, 2005 8:38 am    Post subject: Reply with quote

Is the surge under light/normal throttle or full throttle?

Try disconnecting the battery cable for an hour or so. That will cause the ECM to reset, forcing it and "learn" the vehicles sensor inputs again over the next 300 or so miles. Also check the throttle body. The K&N filters let more dirt through so the TB probably needs to be cleaned.
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
raelayotte
Member


Joined: 22 Jun 2005
Location: MIchigan

PostPosted: Wed Jun 22, 2005 2:07 pm    Post subject: Reply with quote

it surges at normal throttle it last for about 1 sec i cleaned the tbi
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Wed Jun 22, 2005 2:59 pm    Post subject: Reply with quote

Aside from resetting the ECM, try putting a gauge on the fuel rail and check the pressure. I forget the exact numbers but it should be somewhere between 30-40psi. If you're pressure is low you either have a blocked line, a bad check valve or the fuel pump assembly has a problem.

Contrary to popular belief, 97-01 XJ's do have a fuel filters. They are one part of the fuel pump assembly on the top of the gas tank...so you need to drop the tank to get to it.
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
raelayotte
Member


Joined: 22 Jun 2005
Location: MIchigan

PostPosted: Fri Jun 24, 2005 9:35 pm    Post subject: Reply with quote

it dont do it all the time it might be a mile down the road could be a 100 feet down the road and some days it will not do it
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
raelayotte
Member


Joined: 22 Jun 2005
Location: MIchigan

PostPosted: Fri Jun 24, 2005 9:36 pm    Post subject: Reply with quote

theres about 38 psi
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
raelayotte
Member


Joined: 22 Jun 2005
Location: MIchigan

PostPosted: Wed Jun 29, 2005 8:05 am    Post subject: Reply with quote

all fixed one of the new wires were bad
Very Happy
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group