Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

93 Grand Crerokee Laredo Cruise control doesn't work


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
Steve35897
Member


Joined: 12 Jul 2005
Location: Johnstown, Colorado

PostPosted: Tue Jul 12, 2005 8:59 pm    Post subject: 93 Grand Crerokee Laredo Cruise control doesn't work Reply with quote

I just bought a 93 Grand Cherokee Laredo and the cruise control doesn't work. I don't have a check engine light.

Any help would be greatly appreciated.

Thanks
_________________
Steve
Back to top
View user's profile Send private message
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Tue Jul 12, 2005 10:23 pm    Post subject: Reply with quote

Check the vacum lines that come out of the fire wall on the passenger side (Tiny hard plastic lines..) and the ones that go under the battery..

They are not monitered by the computer..

Carl
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Wed Jul 13, 2005 4:12 am    Post subject: Reply with quote

Under the battery is a good place to look because the acid that leaks out of the battery runs down and build up on the battery tray, then eventually down past the tray and onto anything thats underneath it.
_________________
06 Rubicon
4" RC sus. lift, 1" PA BL
Warn rear bumper/carrier, Xenon flat fender flares, Warn 9.5Ti winch
PICS
Back to top
View user's profile Send private message Send e-mail
theskitzofrantic
Member


Joined: 14 Aug 2004

PostPosted: Wed Jul 13, 2005 1:17 pm    Post subject: Reply with quote

I have a 97 Orvis that the cruise doesn't work on too. The cruise light in the dash comes on but it will not maintain speed.
Back to top
View user's profile Send private message
Steve35897
Member


Joined: 12 Jul 2005
Location: Johnstown, Colorado

PostPosted: Thu Jul 14, 2005 7:00 pm    Post subject: Reply with quote

I just checked the vacuum lines today. They seem to be fine. I unplugged the vacuum line from the servo I guess it is under the hood, then started the engine. There is good vacuum at the line when idling.

I also removed the switches from the streering wheel, they seem to be fine.

After finding nothing that seems to be wrong I cvontinued to try to get it to work while driving. I finally did but it seems really strange to me.

Does the cruise control work the way that most other cruise controls do?

With the On/Off switch On, I press the Set/Decel and the Resume/Accel simultaneously and the cruise starts to work. But it ocassionally stops working.

I haven't played with it enough to find out if pressing the resume after it stops working might restart it.

Does any of this sound familiar to anyone? Or does it just sound like a loose/ crossed connection somewhere?

Thanks
_________________
Steve
Back to top
View user's profile Send private message
jeepjeepjeep
Member


Joined: 28 Nov 2005
Location: elizabethtown.ky

PostPosted: Sun Dec 04, 2005 8:46 pm    Post subject: Reply with quote

the broblem on my 93 was electronic in the srteering wheel whenever i turned too much it would shut off or not engage at all somethhing in the switch went bad so try that out
_________________
1993 jeep grand cheerokee
1994 jeep grand cheerokee wrecked
Back to top
View user's profile Send private message Send e-mail AIM Address
jekwone
Member


Joined: 09 Jul 2005

PostPosted: Sun Jun 25, 2006 5:11 am    Post subject: Reply with quote

Steve...- I got the same issue going on.... did you resolve it? Any advice?
Back to top
View user's profile Send private message
XTOZJ
Member


Joined: 30 Mar 2006
Location: ST CHARLES MO

PostPosted: Wed Jun 28, 2006 4:40 pm    Post subject: Reply with quote

After turning it on try just to push the Set button once and dont touch the Accel button at all and mine stays on......94 GLC.
_________________
It's a JEEP thing.... you wouldn't understand!
If it ain't a JEEP, its a wannabe!
Happy trails to you!
Whats in your holster?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group