Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

No Bus


 
Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message
markm
Member


Joined: 20 Nov 2005

PostPosted: Sun Nov 20, 2005 3:25 pm    Post subject: No Bus Reply with quote

I own a 2000 Wrangler. I have occassions where the check engine light will come on, the air bag light will come on, and the tach and speedometer will shut down and it says No Bus in the ditital odometer. Bus is a computer term but what does No Bus mean?
Back to top
View user's profile Send private message Send e-mail
WhatWasIThinkin
Member


Joined: 02 Jan 2004
Location: Epping New Hampsha

PostPosted: Sun Nov 20, 2005 5:06 pm    Post subject: Reply with quote

Im not sure what the no bus this means, but Im sure that your contacts behind the dash have gotten dirty or maybe corroded. This will cause the same symptoms that you have. Not always, but ussually happens to Jeeps that are left topless and are subjected to the elements.

One quick fix.....banging on the top of the dash will sometimes be a fix. But if this is the real problem, taking the dash apart and cleaning the wire conection and dielectric grease sealing them is the best cure.
_________________

Real Jeeps dont wear Bra's
Back to top
View user's profile Send private message Send e-mail
oldjeepman
Member


Joined: 26 Dec 2005
Location: Lincoln,Ne.

PostPosted: Mon Dec 26, 2005 8:47 pm    Post subject: no bus Reply with quote

hey my 99 also had no bus on it and the dealer replaced the dash wiring harness on it ,but i was also still under warranty at the time.
Back to top
View user's profile Send private message
99TJ
Member


Joined: 23 Dec 2005
Location: Denver

PostPosted: Wed Dec 28, 2005 1:25 pm    Post subject: Reply with quote

"No Bus" is just the gauge cluster telling you that it is not receiving the parallel data bus from the computer, because the connection has come loose.

This is a common problem with the earlier TJs. Jeep was supposed to have fixed it in recent models. I have to pull my gauge cluster out and re-seat it about once or twice a year because of this problem. It usually comes loose when the weather changes from summer to winter.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group