Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

99 TJ Instrument problems


 
Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message
Bmansoftball
Member


Joined: 14 Dec 2005

PostPosted: Wed Dec 14, 2005 7:50 am    Post subject: 99 TJ Instrument problems Reply with quote

Has anybody experienced instrument panel problems? Mine quits working for awhile then works for a little bit then quits, then works. I've replaced the instrument cluster because that's what the dealer said it was after cleaning the connector then finally replacing the connector. But I still experience the same problem. Anybody have any suggestions?
Back to top
View user's profile Send private message
Keithtj
ARLI$$
ARLI$$


Joined: 05 Jan 2004
Location: Out of jail now

PostPosted: Wed Dec 14, 2005 8:33 am    Post subject: Reply with quote

do all of your gauges die, and the airbag light comes on? If so, then it is a bad connection behind your dash. Usually a hard wack on the top of your dash will fix the problem, or removing your dash and cleaning the connecters should work. Although you did say you did that once already, maybe try it again.
_________________

My Morning Jacket
Back to top
View user's profile Send private message Visit poster's website AIM Address
Bmansoftball
Member


Joined: 14 Dec 2005

PostPosted: Wed Dec 14, 2005 8:39 am    Post subject: Reply with quote

Thanks. Yep, everything dies, and air bag light comes on. On the replacement instrument cluster it shows no bus in the miles slot.I'll try cleaning that again. Could this be a ground problem also?
Back to top
View user's profile Send private message
ehirner
Moderator
Moderator


Joined: 01 Jan 2004
Location: Eastern PA

PostPosted: Wed Dec 14, 2005 6:46 pm    Post subject: Reply with quote

Guess how many threads I found with a quick search of the TJ forum for "instrument cluster"?

http://jeephorizons.com/phpbb/viewtopic.php?t=6031&highlight=instrument+cluster
http://jeephorizons.com/phpbb/viewtopic.php?t=4056&highlight=instrument+cluster
http://jeephorizons.com/phpbb/viewtopic.php?t=1852&highlight=instrument+cluster
http://jeephorizons.com/phpbb/viewtopic.php?t=3802&highlight=instrument+cluster
http://jeephorizons.com/phpbb/viewtopic.php?t=2006&highlight=instrument+cluster
http://jeephorizons.com/phpbb/viewtopic.php?t=1517&highlight=instrument+cluster

Six.
_________________
04 Unlimited
Back to top
View user's profile Send private message AIM Address
Bmansoftball
Member


Joined: 14 Dec 2005

PostPosted: Thu Dec 15, 2005 5:03 am    Post subject: Reply with quote

Thanks for the help. I'm going to take the instrument cluster out this weekend and try bending the prods up and clean them up and see if that does the trick. I'll post back if it takes care of problem.
Back to top
View user's profile Send private message
Bmansoftball
Member


Joined: 14 Dec 2005

PostPosted: Mon Jan 23, 2006 9:39 am    Post subject: Reply with quote

To no avail, still happens. Blasted thing anyway. This is getting ridiculous taking the cluster out and bending tabs and putting back in only to work for a few days then right back to not working. The engineer who came up with this should be shot!
Back to top
View user's profile Send private message
KnightFire
Member


Joined: 07 Jan 2004
Location: Hanover, MD

PostPosted: Mon Jan 23, 2006 1:31 pm    Post subject: Reply with quote

Have you tried coating the connections with some dieletric grease? That may help connectivity, if it's 'barely' making contact...just an idea for ya...


KnightFire
_________________
2002 TJ Wrangler X
Patriot Blue 4.0L
Check Website for Mods/Photos

Amsoil Dealer
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group