Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

BIG BATTERY PROBLEM! Help please!


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
coolest_stan
Member


Joined: 31 Mar 2005

PostPosted: Tue Jan 10, 2006 12:52 pm    Post subject: BIG BATTERY PROBLEM! Help please! Reply with quote

well heres what happened. My battery is fine one day, so Im drivign around. I turn off the engine, come back outside 5 minutes later, and the car wont even start. WHen I turn the ignition NOTHING happens at all. Like the car is dead. SO then I get my uncle to jumpstart it and and it works. Wellt he next morning, I have to get it jumpstarted again, and thenI drive it to autozone. I take out the battery, and the guy at autozone checks it in his little machine. He says its FINE! 14 volts!
he tells me maybe the connectors are dirty.
So I go back outside and put the battery back in, and kind of wipe the connectors with my hands a little (they look real clean, no corrosion).
And the car gets the eletricity!!!
SO I think everything is fine, and eveyrthing works for a day
THen the next day, I turn on the car to go to school, and the idel is really rough. I jsut ignore it and drive to school. WHen school is out, I get in my car to go home, and NOTHIGN HAPPENS! Like before, it seems liek the batteyr is dead. The door lights don;t even come on!!!
THen I get a friend to jump me, and the car starts.
What is going on!!!!!!!!!!!!!!!!!!!!!

i just cleaned the battery teminals, didnt do much. Here is the latest series of events:
I clean the terminals and connectors off, replace the battery connectors onto the terminals. The car gets electrcity! 9I can tell because the security system automatically turns on).
SO I shut off the security system and I go to start the car. ANd immediately everything dies.

WHen I go back to the batteyr and wiggle it around, the security system will start up again, and then when I go try to start the car again, it dies immediately... again.

So whats going on!!!! bad starter maybe? Do i need completely new terminals?(the ones i have now are kind of loose and still have corrosion over them)

can't be a bad battery or alternator (I measured it 12.6 volts).
Back to top
View user's profile Send private message
coolest_stan
Member


Joined: 31 Mar 2005

PostPosted: Tue Jan 10, 2006 12:52 pm    Post subject: Reply with quote

update:
i posted on another forum and they think its the cables or eithe rthe battery has a dead cell.
anyway to check for a dead cell, and how would I replace the cables of my battery? Could I do it myself? and what toosl would I need?
Back to top
View user's profile Send private message
Code3TJ
Hacker
Hacker


Joined: 01 Jan 2004
Location: Uzbekistan

PostPosted: Tue Jan 10, 2006 1:27 pm    Post subject: Reply with quote

I was going to ask if you'd checked the cables too. Yes, you can get a hydrometer at the parts store to check the cells of the battery. Also you mentioned that the terminals are corroded. Clean them thoroughly. Wink
_________________
Nothing to see here.
Back to top
View user's profile Send private message
coolest_stan
Member


Joined: 31 Mar 2005

PostPosted: Tue Jan 10, 2006 6:31 pm    Post subject: Reply with quote

so you don't think i need new cables? I actualyl think its the battery now, because when I put a "load' on it, i.e try to start my car, it just dies. SOunds like a dead cell to me....
what do you guys think
Back to top
View user's profile Send private message
Code3TJ
Hacker
Hacker


Joined: 01 Jan 2004
Location: Uzbekistan

PostPosted: Tue Jan 10, 2006 7:27 pm    Post subject: Reply with quote

No, I'm saying if I were you, I'd check your cables. Wink
_________________
Nothing to see here.
Back to top
View user's profile Send private message
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Tue Jan 10, 2006 8:07 pm    Post subject: Reply with quote

Yup.. I am thinking cables... Mr. Green
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
coolest_stan
Member


Joined: 31 Mar 2005

PostPosted: Tue Jan 10, 2006 8:35 pm    Post subject: Reply with quote

ok cool.... i bet the cables are the problem!
Now the problem is, I don't kno whow to "check" if the cabvles are wrong. I looked for lumps but it is too hard to tell (there is tape around al the wires and crap)
how would I replace the cables anyways? WOuld I have to rerun the cales thorughout the entire car?
I am thinking about just changing the battery connectors and seeing if that will help. (can I change the battery conenctors myself? and what tools will I need? and any recommendations on waht kind of batery connectors to get)


Last edited by coolest_stan on Wed Jan 11, 2006 9:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
coolest_stan
Member


Joined: 31 Mar 2005

PostPosted: Wed Jan 11, 2006 9:26 pm    Post subject: Reply with quote

alright, heres the rpoblem with replacing the cables. There are two cables leading to each terminal!
each terminal has a cable that looks liek it will be very easy to replace ( one of the negative ones goes directly to the chassis and one of the positive ones goes directly to a box (the starter I think)). However, the second cables are oens that go into the interior of the jeep! Can I jsut replace the ones that lead to the starter and chassis?
(the third cable is just the power calbe leading to my subwoofers)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group