Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

cherokee automatic shifting problems


 
Post new topic   Reply to topic     Forum Index -> Drivetrain
View previous topic :: View next topic  
Author Message
wheelin1338
Member


Joined: 04 Jan 2006

PostPosted: Mon Jan 23, 2006 2:32 pm    Post subject: cherokee automatic shifting problems Reply with quote

i have a 1995 cherokee with the auto trans, on occasion the tranny seems to engage at like 2200 rpms, also it sometimes doesnt shift to higher gears. but this is while your going about 30 or 40 mph, then in another 10 mins or once u stop and go again it could be fine, maybe a bad sensor or something? let me know what u think!
Back to top
View user's profile Send private message Send e-mail AIM Address
1fox2go
Member


Joined: 01 Dec 2004
Location: Fishersville, Virginia

PostPosted: Mon Jan 23, 2006 7:16 pm    Post subject: Reply with quote

TPS (Throttle positioning sensor)

maybe?

hows the fluid?
_________________
96 Cherokee 7.5 inch TnT long arm Locked F/R, D44 rear, 4.56s, 35x12.50 Muds/36x12.50 TSLs
Back to top
View user's profile Send private message Send e-mail AIM Address
wheelin1338
Member


Joined: 04 Jan 2006

PostPosted: Mon Jan 23, 2006 7:17 pm    Post subject: Reply with quote

fluid is fine, i think it may be a little over full could that do it?
Back to top
View user's profile Send private message Send e-mail AIM Address
1fox2go
Member


Joined: 01 Dec 2004
Location: Fishersville, Virginia

PostPosted: Tue Jan 24, 2006 10:07 am    Post subject: Reply with quote

not really as long as its nots like way over full

what about the filter when was it changed last?
_________________
96 Cherokee 7.5 inch TnT long arm Locked F/R, D44 rear, 4.56s, 35x12.50 Muds/36x12.50 TSLs
Back to top
View user's profile Send private message Send e-mail AIM Address
wheelin1338
Member


Joined: 04 Jan 2006

PostPosted: Tue Jan 24, 2006 5:33 pm    Post subject: Reply with quote

filter.....hmmm its been a while so maybe ill try that
Back to top
View user's profile Send private message Send e-mail AIM Address
BlueJ
Member


Joined: 19 Jan 2004
Location: Wilmington DE

PostPosted: Wed Jan 25, 2006 7:54 am    Post subject: Reply with quote

My son has reported the exact same problem with the '96 XJ I bought for him last year. We haven't been able to figure it out. Please post up when you fix the problem...
_________________
Delaware Jeep Association (Trail Boss 2003 - 2003)
Blue Mountain Jeep Alliance
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Drivetrain All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group