Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Binding/Grinding noise (Tranny Problems?)

Post new topic   Reply to topic     Forum Index -> Drivetrain
View previous topic :: View next topic  
Author Message

PostPosted: Sun Jul 23, 2006 11:14 pm    Post subject: Binding/Grinding noise (Tranny Problems?) Reply with quote

Ok i have a 98 XJ with the AW4 auto. At slow speeds 0-10/15mph or so i get a grinding bindging type noise that kinda sounds like its coming from the tranny-tcase area or rear axle possibly. I first really only noticed it when making a turn from a dead stop. but i hear it when driving straight too. Someone had suggested it might be low tranny fluid, but the tranny fluid actually appeared to be over full. Do you think its tranny related? Or something else. U-joints? low diff fluid? (which i havent checked) any help or advice is much appreciated.
Back to top

Joined: 25 Mar 2006
Location: nor cal

PostPosted: Tue Aug 08, 2006 8:04 pm    Post subject: Reply with quote

Your noise sounds sort of like my new one. At low speeds only when slowing down to 2nd and 1st. It makes a god awfull grinding like a fan hitting something in a circular motion . The fluid has been changed and it stopped for a week and now it bugs again. If I put the clutch in it stops the noise. Don't want to burn up the clutch though it's getting pretty embarrassing...
Chrysler Firepower

Last edited by wildgarden on Thu Feb 03, 2011 10:59 am; edited 1 time in total
Back to top
View user's profile Send private message

PostPosted: Fri Aug 11, 2006 4:31 pm    Post subject: Reply with quote

i thin i might have narrowed down what might be causing the noise. The transmission mount underneath my cherokee is completely shot. Like i mean its rotted out in the middle so it is no longer attached together. I think the tranny is pushing the driveshaft up at an angle when driving causing the already axle-wrapped portion of the drive shaft to bind up. Does this sound logical to anyone else?
Back to top
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Drivetrain All times are GMT - 8 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Visit for write-ups, forums and clubs

Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC. is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group