Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

87 YJ electrical Problems


 
Post new topic   Reply to topic     Forum Index -> YJ Forum
View previous topic :: View next topic  
Author Message
boog44
Member


Joined: 17 Dec 2006
Location: Fort Wayne

PostPosted: Sun Dec 17, 2006 4:13 pm    Post subject: 87 YJ electrical Problems Reply with quote

Hi all.....I am new here....just bought an 87 YJ have been working on it for about a month.....got it running pretty good. Now I'm having little Gremlins driving me nuts!! Evil or Very Mad When I turn on the headlights the engine runs like CRAP!!!!! I have checked the various grounds and cleaned the plugs and prongs.....Now what?????
Back to top
View user's profile Send private message Yahoo Messenger
Tardis
Member


Joined: 07 Aug 2004
Location: Ohio

PostPosted: Wed Dec 20, 2006 2:46 pm    Post subject: Reply with quote

Check the charging system, altenator, battery, wiring, check the starter for a dead short, etc. A crappy diode in the altenator, bad voltage regulator will make the Jeep run bogus under a load.
_________________
98' TJ, 99' XJ
Back to top
View user's profile Send private message Visit poster's website AIM Address
DozerDan
What the deuce?
What the deuce?


Joined: 03 Jan 2004
Location: Where im at

PostPosted: Wed Dec 20, 2006 10:05 pm    Post subject: Re: 87 YJ electrical Problems Reply with quote

boog44 wrote:
Hi all.....I am new here....just bought an 87 YJ have been working on it for about a month.....got it running pretty good. Now I'm having little Gremlins driving me nuts!! Evil or Very Mad When I turn on the headlights the engine runs like CRAP!!!!! I have checked the various grounds and cleaned the plugs and prongs.....Now what?????


Dont drive at night...

check the frame to block ground ?
check the headlight grounds?
check the bat to starter?

If you have then I would try this.... at your own risk.


Pull the switch out of the dash and jump the connections you need for lights. It is possible you have a bad switch, they can do WEIRD things.

Also does it vary if you have the headlights on high or low beam?

Worst case, pull the alt off and bring it to auto zone/pepboys ect and ask them to test it.
_________________
Fabricator for hire.... contact me for info
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> YJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group