Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Performance problems (missing)


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
94BGCherokee
Member


Joined: 22 Jun 2006
Location: Saint Louis, MO

PostPosted: Sun Feb 11, 2007 12:26 am    Post subject: Performance problems (missing) Reply with quote

Ok so to start Jeep runs great excepts for this, 168000 on 94 cherokee, I have 62mm throttle body, hlix bore spacer, borla cat back w\cat delete, stock header, and half a$$ intake setup. Ok so the vehicle starts fun, but acts like it has a miss ocassionally when it idles. It is fine but every once in a while it will studder, nothing major, just an annoyance really, runs fenominal frys the tires down the street. Its weird, I just put new champion truck plugs in there .035 gap, new cap and rotor, and it seemed great. The only thing is I went from premium (93 oct) to regular (87 oct) but I dont have a chip or tune so people tell me i shouldnt run premium, waste of money. Im thinking it could be the wires, but its not really that bad and it doesnt cut out a high rpm. Im thinking though with that 62mm throttle body and spacer, it feels kind of doggy until after 2800 rpm, but im thinking im not getting enough fuel since 4.0's run lean (RIGHT???) do I need to add more fuel through a chip or an adj. map sensor? Its not to big of a deal, but help would be greatly appreciated. I have maintained the vehicle well, wrist pins clatter a little, but I drive it hard so what do you expect. I run lucas through the fuel system all the time. If i missed any info please ask and i will post ASAP. Thanks for your time!!!!
Back to top
View user's profile Send private message Send e-mail AIM Address
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Feb 11, 2007 6:08 pm    Post subject: Reply with quote

lucas = shit ,its basically bleach . .035 plug gap , is that what the plate under your hood told you to gap them to ? mine is like .045 on my 91 . what do your plugs look like (color) ? plug wires are cheep and it doesn't matter what they look like on the outside its the inside that counts .

one of my 4.0l runs rich and one lean , so im not sure .

sorry i have no xp in throttle body spacers or throttle body's for 4.0Ls

93 shouldn't be making a difference , the octane rating wont affect it but the lack of additives in 93 vs 87 is pretty big , try out some 89 and see what happens .

some times larger throttle body's and spacers can hurt your low end if you don't really need them eg stock head , stock cylinder bore .

more air = more fuel to keep that perfect mixture .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
94BGCherokee
Member


Joined: 22 Jun 2006
Location: Saint Louis, MO

PostPosted: Sun Feb 11, 2007 6:12 pm    Post subject: Reply with quote

exactly I understand that, thats why im thinking i need more fuel, when I replaced the plug they were nice and white, nothing looked wrong with them, except maybe that it was running lean??? Is it possible it could be a vaccum leak, I dont see how I have looked at all that, unless im overlooking something, I can try the new wires. thanks for the post
Back to top
View user's profile Send private message Send e-mail AIM Address
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Feb 11, 2007 6:53 pm    Post subject: Reply with quote

i would start with wires . you will probably need a computer tuner to fix it up , hopefully you wont need higher pound injectors .

i believe you might just need to adj the map and fuel pressure . not sure how , i think you can get a adjustable fuel pressure regulator . the map would probably be computer adjusted .

i saw an "edge" tuner for a 4.0L made for a 62mm throttle body , maybe check out there website , that might be all you need .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Feb 11, 2007 6:57 pm    Post subject: Reply with quote

http://tunertools.com/proddetail.asp?prod=EDGE%2DETJ4000&cat=41

thats all i have found in my 30 seconds of googleing . i can't seem to find just the tuner but im sure if you were to buy one it would fix your problem . or something similar
Back to top
View user's profile Send private message Send e-mail MSN Messenger
94BGCherokee
Member


Joined: 22 Jun 2006
Location: Saint Louis, MO

PostPosted: Sun Feb 11, 2007 9:37 pm    Post subject: Reply with quote

thanks for looking and giving me the advice, as soon as i get some time to do that I will let you know the results
Back to top
View user's profile Send private message Send e-mail AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group