Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Suddenly running rough, need help quick


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
avengerXJ
Member


Joined: 18 Jan 2007
Location: Daytona Beach, FL

PostPosted: Sat Mar 10, 2007 8:48 pm    Post subject: Suddenly running rough, need help quick Reply with quote

Two days ago it was running perfect.

I need to drive it 700 miles to TN on Friday, and my temp gauge didn't work so I needed to fix that first. So after testing the sensor, the wires, voltage, grounds, blah blah... I figured out it was the gauge itself. Replaced the gauge and all is well... until I turn it on for the first time since two days ago.

Well, WTF... It starts normally, and it runs, and moves and all that good stuff, but the whole friggin engine is vibrating. It vibrates a little at idle (stopped, neutral, clutch in or out), vibrates heavily while accelerating, but smooth as heck when coasting in-gear (well, technically engine braking). But the second I step on the gas, or clutch, the vibrations come back.

The only two things that I have changed since two days ago was the temp gauge (not the whole cluster, just the one gauge), and I installed a new rubber boot around my shifter.

I need help finding the problem quickly, as I only have 6 days. I need to leave for my trip on friday.

I'm seriously going to cry if I can't get this running good in time for friday. I've been working on this Jeep since October and everything was good and now this is going to ruin my whole trip. PLEASE help.
Back to top
View user's profile Send private message
Tardis
Member


Joined: 07 Aug 2004
Location: Ohio

PostPosted: Sat Mar 10, 2007 10:04 pm    Post subject: Reply with quote

It would help if you indicated the year and engine size. Granted most XJ's are all the same, it's nice to know if it's OBDI(81'-95'), or OBDII(96'-present)
Back to top
View user's profile Send private message Visit poster's website AIM Address
avengerXJ
Member


Joined: 18 Jan 2007
Location: Daytona Beach, FL

PostPosted: Sun Mar 11, 2007 8:14 am    Post subject: Reply with quote

Sorry, I though it was in my cig, I must be seeing things.

Its a 1987 XJ 2dr, 4.0L, 5spd, 4x4
Back to top
View user's profile Send private message
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Mar 11, 2007 10:26 am    Post subject: Reply with quote

sounds like a bad IAC or a dirty throttle body .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
avengerXJ
Member


Joined: 18 Jan 2007
Location: Daytona Beach, FL

PostPosted: Sun Mar 11, 2007 11:16 am    Post subject: Reply with quote

Just replaced new plugs, wires, cap, and rotor.

No difference.

Honestly, I'm confused as to why it would just happen so suddenly.
Back to top
View user's profile Send private message
Tardis
Member


Joined: 07 Aug 2004
Location: Ohio

PostPosted: Sun Mar 11, 2007 6:37 pm    Post subject: Reply with quote

Brad The Best wrote:
sounds like a bad IAC or a dirty throttle body .

I think you're on to something Brad. My S-10 hesitated exactly like that a few months ago. The IAC pintle and port was packed with carbon. I cleaned the pintle and port with brakekleen and it runs like a champ. Check your IAC avenger. Also check the breather tubes on the engine.
Back to top
View user's profile Send private message Visit poster's website AIM Address
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Mar 11, 2007 7:25 pm    Post subject: Reply with quote

listen for vacuum leaks , and like Tardis said clean the IAC , i personally use mercury power tune its works a lot better then brake clean but you can use what you like . brake clean is definitely a lot cheaper.
Back to top
View user's profile Send private message Send e-mail MSN Messenger
tag
Member


Joined: 16 Jul 2006
Location: leeds yorkshire england

PostPosted: Mon Mar 12, 2007 8:45 am    Post subject: Reply with quote

Hi,
check the harmonic balancer, it maybe breaking down. (crank pulley) just a thought!......... Rolling Eyes
Back to top
View user's profile Send private message
TheBrat97
Member


Joined: 28 Jul 2006
Location: Dallas, TX

PostPosted: Mon Mar 12, 2007 9:26 am    Post subject: Reply with quote

tag wrote:
Hi,
check the harmonic balancer, it maybe breaking down. (crank pulley) just a thought!......... Rolling Eyes


Not a bad idea but I think it would probably still vibrate while coasting.
_________________
2005 TJ 2" Lift 33" TrXuS M/T's
Back to top
View user's profile Send private message AIM Address
tag
Member


Joined: 16 Jul 2006
Location: leeds yorkshire england

PostPosted: Mon Mar 12, 2007 9:46 am    Post subject: Reply with quote

yeah, your right , but a unbalanced wheel runs smooth at the right speed.
Back to top
View user's profile Send private message
TheBrat97
Member


Joined: 28 Jul 2006
Location: Dallas, TX

PostPosted: Mon Mar 12, 2007 2:44 pm    Post subject: Reply with quote

true true
_________________
2005 TJ 2" Lift 33" TrXuS M/T's
Back to top
View user's profile Send private message AIM Address
avengerXJ
Member


Joined: 18 Jan 2007
Location: Daytona Beach, FL

PostPosted: Wed Mar 14, 2007 1:11 pm    Post subject: Reply with quote

Alas, the problem located... @#$% clogged fuel injectors. I guess it wouldn't hurt to replace them after 315k miles.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group