Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

headlights, fule pump don't always shut off ?


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
carpetrugger
Member


Joined: 17 Mar 2007

PostPosted: Fri Apr 20, 2007 10:19 am    Post subject: headlights, fule pump don't always shut off ? Reply with quote

Iam working on my 87. I know the batt. has a shorted cell but it holds a charge for a few days and don't want to replace untill I get this problem fixed so I don't damange the new one. As long as the battrey has a good charge the fule pump will come on when the key is turned on and run for a few seconds and stop when the pressure builds up. It holds the pressure without leaking. When I turn the key to the start run possition it starts after about three seconds, this is normal I think. But when the battrey is low, where it turns over to slow to start it the fule pump will start again and continue to run even with the ingnition off and the key out. I have to pull the ground cable off the batt. to get it to stop running. When the pump runs like this I here air pressure escaping from under the hood and and fule pump area. This onley happens when the batt. is low. Also a few times I have turned the headlights off and they stay on for a couple of minits but not all the time. I already changed the ingnition switch and this changed nothing. Any idea's? Iam out of them thanks
Back to top
View user's profile Send private message Send e-mail
carpetrugger
Member


Joined: 17 Mar 2007

PostPosted: Sun Apr 22, 2007 10:33 am    Post subject: Reply with quote

Hi and thanks to everone who looked at my post. I called a freind of mine in Calif. who is a elctronics enginer, he also likes to tinker with cars anyways he found a found a wiring diagram on line somepalce for my 87 and told me theres a fule pump relay that is activated by the PCM when the ingnition switch is in the run position. This is working when I first try to start it with the batt. in a low state but after cranking it till the batt. wont turn it over anymore theres not enough charge left in the batt. to operate the PCM (computer) to shut down the fule pump relay but enough to run the pump for awhile longer. He also told me to replace the battery right away because all the elctrical systems can be affected by a low shorted out battery. So I installed a new battery and headlight switch. With the new battery I don't hear the hissing from the fule sytem anymore but I am going to buy a fule pump pressure tester and run a complet check on the system. I will drive it for a few days and let you know if this takes care of the problem in case any of you ever have the same problem. Thanks to all
Back to top
View user's profile Send private message Send e-mail
Glowyrm
Member


Joined: 27 Mar 2007
Location: Long Island NY

PostPosted: Sun Apr 22, 2007 12:33 pm    Post subject: Reply with quote

Your headlights also have a "follow me home" feature. When you turn off your engines then the lights, the headlamps(nothing else) will stay on for 60 sec.
Back to top
View user's profile Send private message MSN Messenger
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Apr 22, 2007 8:58 pm    Post subject: Reply with quote

fuel . sorry had to , i meant no offense
Back to top
View user's profile Send private message Send e-mail MSN Messenger
carpetrugger
Member


Joined: 17 Mar 2007

PostPosted: Wed Apr 25, 2007 7:30 am    Post subject: Reply with quote

None taken. However embarrassed a little but smiling, had to laugh at self. I have put about a hundred miles on the Cherokee so far without any problems. Running on a new battery, maybe to soon to tell if problems are fixed. Sorry about spelling, I have problems with it
Back to top
View user's profile Send private message Send e-mail
carpetrugger
Member


Joined: 17 Mar 2007

PostPosted: Wed May 09, 2007 10:21 am    Post subject: Reply with quote

The new batt. did the trick, no problems with anything. I did replace the headlight switch witch I didn't need to do as Glowyrm said it was working as it was supposed to. I just got the information a day late. Thanks
Back to top
View user's profile Send private message Send e-mail
Glowyrm
Member


Joined: 27 Mar 2007
Location: Long Island NY

PostPosted: Thu May 10, 2007 6:59 am    Post subject: Reply with quote

save the old one. Somebody will need it.
_________________
'87 XJ Chief w/tow pack. Dana 30/44 f/r
3.5" lift 4.88 gears NP242 t-case
Numerous junkyrd doodads
31x10.5's
Back to top
View user's profile Send private message MSN Messenger
cksport
Member


Joined: 17 May 2007

PostPosted: Sun May 20, 2007 12:28 am    Post subject: Reply with quote

my old Camaro did the same thing dead battery
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group