Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

96 grand engine wows


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
grandoldboy
Member


Joined: 01 Jul 2007

PostPosted: Sun Jul 01, 2007 2:06 pm    Post subject: 96 grand engine wows Reply with quote

so my 96 grand cherokee 5.2l jeep has some wierd issues, when u come to a stoplight or a complete stop and take off, the engine acts likes it has 25 horsepower and spits and sputters, like backfire and then finally goes or under hard acceleration it tries to die but dosent. acts fine when maintaining speed. it has a code 51 in the computer, ive read up on this and it means o2 sensor indicates lean condition and computer cannot compensate anymore, so i took it to the shop and they recomended replacing the o2 sensor, so i did and it changed nothing Ive put a new fuel pump, TPS, o2 sensor, ignition coil, plugs, wires, cap and rotor in it and changes nothing... suspecting maybe a vacuum leak, or someother sensor or pcm issues, please help!!!!!!!
Back to top
View user's profile Send private message
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Sun Jul 01, 2007 5:00 pm    Post subject: Reply with quote

Easiest thing to check is vacuum leaks .. Take some carb cleaner and spray it all over the hoses and intake components.. when the engine sputters you found your leak.

Thats a good place to start..
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
grandoldboy
Member


Joined: 01 Jul 2007

PostPosted: Sun Jul 01, 2007 5:58 pm    Post subject: Reply with quote

well i just did all of what you told me, and nothing happened. When in park at idle, the engine idles at the programed rpm, but it runs just a little rough, then if u open the throttle plate full bore, it sounds like the engine is under load, like pulling a trailer, and thats the way it drives to, like im pulling a boat, then it starts to backfire and really run rough while revving up and down, but ive checked and rechecked all the ignition components, and they all seem to be working fine, but i have not detected a leak if there is one. Do u think it could be a cps, or cam position sensor? I also just checked the fuel pressure, when its idling, its at 35psi, then when i rev it, it drops just a little below 30psi, could that meen anything, i just replaced the stupid fuel pump with a napa one. thanks for the help swamp boy!
Back to top
View user's profile Send private message
grandoldboy
Member


Joined: 01 Jul 2007

PostPosted: Sun Jul 01, 2007 6:00 pm    Post subject: Reply with quote

oh, also its throwing a code 51, ive heard people get boggled by this stupid code, hope that helps!
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Sun Jul 01, 2007 7:06 pm    Post subject: Reply with quote

The fuel pressure on a 96 should be 37-41psi at idle. Yours is a little low.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Mon Jul 02, 2007 4:52 am    Post subject: Reply with quote

OK>. that sounds like your timing is off..

The only thing I know of that would affect that is the Crank position sensor so you are back to that..

(Passenger side where the engine and tranny meet. )

Good luck..
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Mon Jul 02, 2007 6:14 am    Post subject: Reply with quote

I found this in the OBD codes section.
51 Oxygen sensor stuck at lean position (this may be tripped by a bad MAP sensor system causing a rich condition. If you get hot rough idle and stalling, especially on deceleration, accompanied by flooded engine and difficulty restarting, that can be a bad MAP sensor causing the O2 sensor to try to compensate. If you get poor cold driveability, stumbling and bucking, and acceptable warm driving with poor gas mileage (a drop of 10 mpg or more), that is usually the O2 sensor.

Try testing the MAP sensor, it's worth a try.



_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group