Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

What the heck is going on?


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
GREATONES96
Member


Joined: 28 Jul 2005
Location: ARIZONA

PostPosted: Thu Jul 05, 2007 8:38 pm    Post subject: What the heck is going on? Reply with quote

Sorry this will be a long one,,Past couple months while driving my jeep would act as if it had vapor lock for a couple seconds and oil gauge and temp guage would go to zero and then it would drive fine again.Well the other day it did it again and shut off this time and would not restart,sounded as if it had no spark,i took the core out of the fuel rail to see if there was fuel pressure and looked like plenty.And after a few hours and trying to restart it all of a sudden out of the blue it starts again and is running fine.And in the mean time i have replaced the cap and rotor,spark plugs and wires and the coil, because when the engine light was on it read miss fire. well it has been running again and now is starting to sound like maybe there is a miss fire at idle but while i drive it it runs strong,oh and it is a 97 xj 4.0 with 190.000 miles on it.Is there any one that can help please,,very frustrating..........Thank you in advance.. Shawn
Back to top
View user's profile Send private message Visit poster's website
mattbred
Member


Joined: 03 Jun 2007

PostPosted: Thu Jul 05, 2007 10:21 pm    Post subject: Reply with quote

Check your battery connections, voltage while not running, and voltage while running. Sounds like you got some funky electrical gremlins..
Back to top
View user's profile Send private message
JeepinNH
Member


Joined: 13 Sep 2005
Location: New Hampshire

PostPosted: Fri Jul 06, 2007 10:15 am    Post subject: Reply with quote

Some of this sounds like the crank position sensor except for the loss of guages. That seems like it would point to the computer or lack of power to it. Intermittent issues are brutal. It's gotta be electrical.
_________________
Mike

Present: 99 Cherokee
Past: 86, 87 Cherokee; 94 Grand Cherokee
Back to top
View user's profile Send private message
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Fri Jul 06, 2007 7:06 pm    Post subject: Reply with quote

i would guess a bad ground .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
88WOWJ
Member


Joined: 12 Aug 2006
Location: Hinesville Ga

PostPosted: Sat Jul 07, 2007 4:44 am    Post subject: What the Heck is going on? Reply with quote

It sounds that your fuel pump is bleeding pressure off.
Try this the next time it wont start. Turn the ignition switch and listen for the pump to prime. Turn off the ignition switch. Turn the ignition switch
back on again and listen for the pump to prime. Do this at least 3 times.
Try to start the engine, if it starts you may have a fuel pump problem.
The pressure is leaking off or it is not making enough pressure.
_________________
1988 Wagoneer Limited XJ Tellico Tested
Rocklizards panels, Tomken rear bumper and front Tow brackets, Rocket air intake, 2 inch lift,
30x950x15, 1991 coolant system with electric fans, 8,000 mile marker winch
1991 Cherokee Limited
Back to top
View user's profile Send private message Send e-mail
rbjeepster
Member


Joined: 11 Jul 2007
Location: Brentwood,California

PostPosted: Wed Jul 11, 2007 11:03 pm    Post subject: Re: What the Heck is going on? Reply with quote

i had a very similar problem it wouldn't start out of no where i would wait and hour and it would start with no problems. CHECK your crank positioning sensor its on the drive side of the tranny right at the top of the bell housing next time your xj doesn't start try unplugging the connector to that senor then plugging it back in worked for me and i found the problem right away
Back to top
View user's profile Send private message
Duncan
Member


Joined: 09 Jul 2007

PostPosted: Thu Jul 12, 2007 3:18 am    Post subject: Reply with quote

I am guessing electrical problems of some sort.
Maybe something with the computer.
Back to top
View user's profile Send private message Send e-mail AIM Address
Teriod
Member


Joined: 19 Jun 2007
Location: California

PostPosted: Thu Jul 12, 2007 4:25 am    Post subject: Reply with quote

most of these posts are very good ideas and should be checked, in addition if you vehicle has some sort of ignition control module i would check/change that
Back to top
View user's profile Send private message
cjhauler
Member


Joined: 18 Jul 2007

PostPosted: Wed Jul 18, 2007 7:07 pm    Post subject: Reply with quote

I am having a similiar problem with my 94 XJ with 183,000! I have always been meticulous with maintenance and this is the first time this Jeep has ever given me any problems. In my case, it's as if the transmission disconnects for a split second and then reconnects. I did notice the tach dropped to zero and then right back to correct rpms. It's hard to tell if the engine drops out or the transmission disconnects. I'll try some of the suggestions here and see what happens. Will post results, if any.
Back to top
View user's profile Send private message
cjhauler
Member


Joined: 18 Jul 2007

PostPosted: Sat Aug 04, 2007 7:03 pm    Post subject: Reply with quote

Just a quick follow up, Replaced the crank position sensor two weeks ago and no problems since! Thank for the suggestions, seems to have corrected it! Very Happy
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group