Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

O2 sensor HELP


 
Post new topic   Reply to topic     Forum Index -> Electronic
View previous topic :: View next topic  
Author Message
monkeyman3875
Member


Joined: 06 Jul 2005
Location: Charlotte, NC

PostPosted: Mon Jul 09, 2007 7:59 am    Post subject: O2 sensor HELP Reply with quote

I just got a new Catalytic converter and long story short, they moved the wires for my O2 sensor and they got ripped apart by the driveshaft. Problem is, it was the harness side that got destroyed. I would like to re-wire it but I'm not much of an electrician and need some help.

Below are the pictures of the piece that was ripped out. I either need a new plug, new silver pieces (check below) or a combination of the 2. I just want to reconnect the wires, I don't want to take it to the dealer. Thanks for the help.












_________________
-1997 Stock XJ
-4.0 L
-4-speed automatic
-130k Miles (and counting)-> let me know of any preventative maintenance you guys can think of. PM me.
Back to top
View user's profile Send private message Send e-mail
monkeyman3875
Member


Joined: 06 Jul 2005
Location: Charlotte, NC

PostPosted: Tue Jul 10, 2007 5:31 am    Post subject: Reply with quote

Nothing? Please, I need some help.
_________________
-1997 Stock XJ
-4.0 L
-4-speed automatic
-130k Miles (and counting)-> let me know of any preventative maintenance you guys can think of. PM me.
Back to top
View user's profile Send private message Send e-mail
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Tue Jul 10, 2007 7:17 am    Post subject: Reply with quote

OK, if you really want to salvage it. What I would do, is take a small screwdriver and small needlenose, uncrimp the ends of the pins and stick the wires back in. Then clamp em back up. If they are loose add a drop of solder!
I'm not sure how the plug came apart, but you'll probably have to feed the wires through the plug housing before you reattach the pins, so that you can just pull them back into it.
Also if the wires were too short, now is the time to lengthen them.

_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
Duncan
Member


Joined: 09 Jul 2007

PostPosted: Tue Jul 10, 2007 10:11 am    Post subject: Reply with quote

Consider using the pins for AMP CPC conectors... There are many different shapes and sizes... Here is a catalog page to start... Look at that one and adjecent pages to see if any of those can be made to work... Mouser is the comany and their homepage is mouser.com

If you find the part you want simple call them at 1-800-346-6873 and give them the part number...

If you need any help selecting a pin let me know..
Back to top
View user's profile Send private message Send e-mail AIM Address
monkeyman3875
Member


Joined: 06 Jul 2005
Location: Charlotte, NC

PostPosted: Tue Jul 10, 2007 10:36 am    Post subject: Reply with quote

thanks I'll give it a shot, but could some one post a picture of theirs. I think when I put it back together I might have switched the leads and mixed up where they go.

Must be compatible with a '97 XJ with 4.0L straight 6 and, if it matters, an AW4 transmission. Hopefully the colors will match.
_________________
-1997 Stock XJ
-4.0 L
-4-speed automatic
-130k Miles (and counting)-> let me know of any preventative maintenance you guys can think of. PM me.
Back to top
View user's profile Send private message Send e-mail
monkeyman3875
Member


Joined: 06 Jul 2005
Location: Charlotte, NC

PostPosted: Sun Aug 12, 2007 9:13 pm    Post subject: Reply with quote

Asking again, can anyone post a picture of the wires on the harness side of the 02 sensor connection. I think I may have mixed up the leads and need to get it right before I can put it back together.
_________________
-1997 Stock XJ
-4.0 L
-4-speed automatic
-130k Miles (and counting)-> let me know of any preventative maintenance you guys can think of. PM me.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Electronic All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group