Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

High beam low beam issue on 99 TJ


 
Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message
ScottF
Member


Joined: 27 Aug 2007

PostPosted: Mon Aug 27, 2007 10:03 am    Post subject: High beam low beam issue on 99 TJ Reply with quote

Howdy,

I bought this Jeep "used" as a dealer sample in Feb of 99 w/ 5000 miles. It has been a great vehicle. Its got about 48000 miles on it (not my daily driver anymore) and besides the instrument pod dropping out occasionaly (I know how to fix, but the fist solution is working right now)I have had no real problems, until now.

The headlights started acting up. Switching from high to low beam, the lights (lo beam) would just drop out. Fiddle with the Hi/Lo switch on the steering column can get the low beams back on. Now they started droping out on their own. Again fiddling with the hi/low switch would get them back on... but it is getting worse.

Can I fix this by replacing the hi/low switch in the column? or is this something worse? Any way to trouble shoot this better than just futzin around with it?

Scott
Back to top
View user's profile Send private message
ehirner
Moderator
Moderator


Joined: 01 Jan 2004
Location: Eastern PA

PostPosted: Thu Aug 30, 2007 2:25 pm    Post subject: Reply with quote

Not sure of a way to trouble shoot the problem but I'd be strongly looking at the multifunction switch (turn signal) on the column as they are known to crap out fairly regularly...especially if the dash has gotten wet or the vehicle is often in a dirty environment.
_________________
04 Unlimited
Back to top
View user's profile Send private message AIM Address
kirkwood007
Member


Joined: 29 Aug 2007
Location: Hills of KY

PostPosted: Sat Sep 01, 2007 4:29 am    Post subject: Reply with quote

I have the same problem. Has anyone ever changed the multifunction switch? How long would it take? Have you had the problem where you press the brake peddal and the left turn signal goes solid? That one tripped me out for a while and I still haven't fixed it.
Back to top
View user's profile Send private message Send e-mail
swamp boy
Cherokee Muderator
Cherokee Muderator


Joined: 01 Jan 2004
Location: New Orleans LA.

PostPosted: Sat Sep 01, 2007 8:35 am    Post subject: Reply with quote

I changed the multi function in my ZJ years ago.. It is not that hard but I had to pull the steering wheel and you have to be carefull with the airbag.

But pretty simple otherwise..


The blinker issue is probably a ground thats crossed or a short where the brake line is touching the bare blinker line.. If you have an aftermarket alarm thats where I would start (looking at those wires..) because alarm install usually involves probing the wires to hook up the light flash and when they do that they brake the shielding on the wires and they could then touch and short out...

If you dont have an aftermarket alarm look at your rear brake lights because blinker and brake share a bulb there (dont they) and could be sending current back thru the blinker circuit.. ..
_________________
BONE STOCK
Unless you include the sawzall work..

Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
kirkwood007
Member


Joined: 29 Aug 2007
Location: Hills of KY

PostPosted: Sat Sep 01, 2007 10:49 am    Post subject: Reply with quote

Thanks for the info. Its very intermittent and the idea of the single bulb causing problems had occured to me. I changed the lights about 3 weeks ago and haven't had any problems yet. But like I said it just comes and goes. I don't have an alarm on mine but who knows what the goof did with it before me. Some people just shouldn't be allowed to buy jeeps. It should be like rescueing a mistreated dog where they come see if you are worthy of the animal. My jeeps previous owner was definately not worthy of my animal. Hahaha!
Back to top
View user's profile Send private message Send e-mail
ehirner
Moderator
Moderator


Joined: 01 Jan 2004
Location: Eastern PA

PostPosted: Sat Sep 01, 2007 7:40 pm    Post subject: Reply with quote

kirkwood007 wrote:
I have the same problem. Has anyone ever changed the multifunction switch? How long would it take? Have you had the problem where you press the brake peddal and the left turn signal goes solid? That one tripped me out for a while and I still haven't fixed it.

Yup...same problem with brake and constant turn signal. Replace the multifunction switch.
_________________
04 Unlimited
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group