Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Cherokee accelerator problem, help please


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
cottager
Member


Joined: 11 Sep 2007
Location: UK

PostPosted: Tue Sep 11, 2007 6:41 am    Post subject: Cherokee accelerator problem, help please Reply with quote

Hi all
Posting this on behalf of someone else: if I'd be better asking in another of the forums please let me know. Can't add any more details at present and won't be able to comment myself on any replies, but will pass all responses on to the enquirer (who has a customer's vehicle for repair). This is the info he's given me:

1997 P-reg Jeep Cherokee, 2.5 Turbo Diesel (in UK)
There is no response from the accelerator pedal -- it's totally dead. A new pedal assembly has been fitted, but still the same. It was suggested it could be the EGR valve, but that checks out OK. If anyone has had a similar problem or can make any suggestions, anything to go on would be appreciated. The vehicle starts first time, every time.

Thanks in advance!
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Tue Sep 11, 2007 8:39 am    Post subject: Reply with quote

If the linkage at the throttle body is turned manually does it effect the idle when running?
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Tue Sep 11, 2007 4:57 pm    Post subject: Reply with quote

Sounds like either a cable problem or a broken 'butterfly' lever on the throttle body.
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
cottager
Member


Joined: 11 Sep 2007
Location: UK

PostPosted: Wed Sep 12, 2007 11:56 am    Post subject: Reply with quote

Thanks both, for the replies -- will pass on to the enquirer and if needed report back with more when he's checked out what you've suggested, though he's away a couple of days so won't be straight away.
Thanks again for the help so far.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group