Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

engine surge with ac/heat


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
Horror Biz
Member


Joined: 31 Aug 2007

PostPosted: Mon Sep 17, 2007 9:44 am    Post subject: engine surge with ac/heat Reply with quote

With HVAC use I'm getting a pretty regular engine surge. It's not noticable while driving but is obvious at a stand still or while coasting. I've asked around at a couple of places and have gotten different answers ranging from, I need to recharge my ac, to I need to change my air filter.....Anyone have any ideas? She's a 2000 pushing 190,000 if that helps at all.
Back to top
View user's profile Send private message
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Mon Sep 17, 2007 6:12 pm    Post subject: Reply with quote

well a new air filter doesn't hurt , but i would search for a vacuum leak .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
TheBrat97
Member


Joined: 28 Jul 2006
Location: Dallas, TX

PostPosted: Tue Sep 18, 2007 9:48 pm    Post subject: Reply with quote

I have the same problem...whenever I turn my a/c on while idling, the Jeep lunges forward or tries to. I always thought it was just the computer compensating for the parasitic drag on the engine.
_________________
2005 TJ 2" Lift 33" TrXuS M/T's
Back to top
View user's profile Send private message AIM Address
dancerman
Member


Joined: 08 Jun 2006
Location: Atlanta

PostPosted: Thu Sep 20, 2007 2:51 am    Post subject: Reply with quote

My '99 has very noticable surging with A/C use when I'm driving at lower speeds (40 mph and lower). Its most severe when the engine load is light or if you are off the throttle (downhill). It's very annoying. It seems to run normal at idle or higher speed or under a load. It's always done this since new. I think it's a design flaw.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group