Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Strange 5.9 ZJ issue + pull codes (already tried ODO trick)


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
5.9 ZJ
Member


Joined: 25 Dec 2004
Location: Toledo

PostPosted: Mon Sep 17, 2007 8:20 am    Post subject: Strange 5.9 ZJ issue + pull codes (already tried ODO trick) Reply with quote

Hi all -

After an hour of searching I finally found my user name so I could reset my account... needed the experts on this one!

Okay, '98 5.9 ZJ ~ 79K, never any real bad issues (with the exception of the rear going out) until about a week ago. After driving for 10 minutes or so, I stopped at a red light. When I tried to take off it felt like it was really bogged down and the check engine light came on. After a few seconds it "worked itself out" and accelerated normally. Another 1/2 hour of driving was normal. 3 days later, shortly after the check engine light had extinguished itself, the same thing happened. I tried the various "key on key off odometer reset" methods to get the code to display, but no dice.

So - does anyone know how to get the codes to display on a 98 5.9?

Any clues as to what my bogging issue might be?

Thanks a million in advance!

Brian


Last edited by 5.9 ZJ on Mon Sep 17, 2007 11:35 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Mon Sep 17, 2007 9:13 am    Post subject: Reply with quote

http://jeephorizons.com/phpbb/viewtopic.php?t=2719

Newer (OBDII) models - Put the key into the ignition, push down the odometer reset button, then turn the key to RUN with your finger on the button - and then release the button. The odometer will go through 1111111 through 999999, then display the car's serial number. It will then show the error codes (it might show them starting with P). If this method does not work, try the OBDI method.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
5.9 ZJ
Member


Joined: 25 Dec 2004
Location: Toledo

PostPosted: Mon Sep 17, 2007 10:30 am    Post subject: Reply with quote

Orangeamc13 wrote:
http://jeephorizons.com/phpbb/viewtopic.php?t=2719

Newer (OBDII) models - Put the key into the ignition, push down the odometer reset button, then turn the key to RUN with your finger on the button - and then release the button. The odometer will go through 1111111 through 999999, then display the car's serial number. It will then show the error codes (it might show them starting with P). If this method does not work, try the OBDI method.


Hi Orange -

Tried all of the above before posting, no dice.

Any thoughts on what the bogging down on takeoff might be?

Thanks for the input -

Brian
Back to top
View user's profile Send private message Visit poster's website
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Mon Sep 17, 2007 3:35 pm    Post subject: Reply with quote

I would clean up the tb and all sensors real good. Then maybe add some fuel treatment/water remover. You can got to autozone and they will pull the codes for free.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
5.9 andy
Member


Joined: 15 Feb 2007

PostPosted: Mon Sep 17, 2007 4:15 pm    Post subject: Reply with quote

yea, check out auto zone for that, thery are realy cool with it.


now when i go in there the guys is like (another missfire on cylinder 3 again?)
Back to top
View user's profile Send private message Send e-mail
5.9 ZJ
Member


Joined: 25 Dec 2004
Location: Toledo

PostPosted: Mon Sep 17, 2007 4:19 pm    Post subject: Reply with quote

Thanks guys, I'll do all of the above tomorrow.

Have a good one -

Brian
Back to top
View user's profile Send private message Visit poster's website
5.9 ZJ
Member


Joined: 25 Dec 2004
Location: Toledo

PostPosted: Tue Sep 18, 2007 1:40 pm    Post subject: Reply with quote

Okay, had AutoZone pull the code, and it's P0720

Code P0720 - Low Output SPD Sensor RPM Above 15 MPH

So, I guess I'll investigate just where the hell that sensor is and replace it. Hopefully it's in my beat-to-hell Chilton's.

Thanks again for the input guys, I'll report back with the final resolution.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group