Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Clutch Question


 
Post new topic   Reply to topic     Forum Index -> Drivetrain
View previous topic :: View next topic  
Author Message
IYAOYASBABY
Member


Joined: 19 Apr 2007
Location: Norfolk VA

PostPosted: Wed Nov 21, 2007 2:59 pm    Post subject: Clutch Question Reply with quote

Hey all,
I was driving my 86 CJ-7 to a friends house this afternoon, and while in route I lost my clutch pedal it was just sitting flat on the floor board. I have a 258 6cylinder with a T5 tranny.

As far as I can tell the linkage is still connected, and the Jeep continued to drive lucky for me. I'm not to big of a tranny guy I can get around a motor okay, but this out of my scope. I just want to see if anyone has any ideas.

Thanks for any help in advance.


Mitch
Back to top
View user's profile Send private message Send e-mail
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Tue Nov 27, 2007 11:14 am    Post subject: Reply with quote

Is it hydraulic? If so, I would look at the master and slave cylinders for signs of leakage. If you can still drive and there is no loss of power, I would think the clutch itself is still good. Are you able to shift gears at all?
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
IYAOYASBABY
Member


Joined: 19 Apr 2007
Location: Norfolk VA

PostPosted: Fri Nov 30, 2007 12:55 pm    Post subject: Reply with quote

Orange,
Thanks for the reply. I finally firgured it out on Wendsday. I couldn't get back here to post untill today.

The problem was the clutch fork release assembly it sheared off up at the top by the bell crank taking the adjuster with it. I spent days just trying to find a picture of the linkage then it was just a proccess of elimination got the parts in today installed them, and she's up and running agian. Thanks, and be safe.

Mitch
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Drivetrain All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group