Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

poor acceleration


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
gibsonlane1
Member


Joined: 15 Dec 2007
Location: cambridge

PostPosted: Sat Dec 15, 2007 2:13 am    Post subject: poor acceleration Reply with quote

Hi, firstly new member and would like to congratulate you all on a great and informative forum. My problem is as follows:- My Jeep 1998 2.5tdi sport has developed the following problem. Accelerates fine upto about 2000 rpm then tails off taking an age to build up to speed. Have changed fuel filter, turbo checks out fine. have tried locally to find someone who can run a diagnostic but to no avail. I live in March, cambridgeshire so any sugestions, pointer would be gratefully received.

Another problem which i have had since i brought the jeep is poor cabin heating. Have flushed the core both ways and is fine, changed thermostat and flushed system. Blower works fine, Heater control Knob opens and closes fine, the result is warm air at best! Engine running temp is under the 100 on temp gauge.

Many thanks in advance. Cheers
Back to top
View user's profile Send private message
Toliver09
Member


Joined: 16 Oct 2007
Location: Central Illinois

PostPosted: Sun Dec 16, 2007 9:24 am    Post subject: Reply with quote

could be the throttle positioning sensor, they tend to wear after a few years of driving
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
gibsonlane1
Member


Joined: 15 Dec 2007
Location: cambridge

PostPosted: Mon Dec 17, 2007 2:19 am    Post subject: poor acceleration Reply with quote

many thanks for that, i'll get it checked out.

cheers.
Back to top
View user's profile Send private message
gibsonlane1
Member


Joined: 15 Dec 2007
Location: cambridge

PostPosted: Sun Dec 23, 2007 1:56 am    Post subject: Reply with quote

Accelerator cheked out ok. On the morning it was booked into a garage, it would only run for a few seconds the stop. Finally it would'nt fire at all with the guages all failing to register apart from handbrake and airbag warning lights. No engine check light came up! It's been towed into the garage and so far they have found the fuel pump is'nt putting out any pressure. I'll keep you posted!
Back to top
View user's profile Send private message
2wd lame-o
Member


Joined: 28 Dec 2007
Location: Los Angeles, CA

PostPosted: Sun Dec 30, 2007 10:57 am    Post subject: cold out Reply with quote

maybe your fan clutch, some times they freeze up. whilst she is cold and not running try moving the fan blades. they should move freely.
Back to top
View user's profile Send private message
gibsonlane1
Member


Joined: 15 Dec 2007
Location: cambridge

PostPosted: Mon Dec 31, 2007 10:55 am    Post subject: Reply with quote

Many thanks, i'll check that out and keep you posted. Happy new year
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group