Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Help!! 93' YJ running horrible and stalls!!


 
Post new topic   Reply to topic     Forum Index -> YJ Forum
View previous topic :: View next topic  
Author Message
samm95
Member


Joined: 25 Feb 2008

PostPosted: Mon Feb 25, 2008 1:00 pm    Post subject: Help!! 93' YJ running horrible and stalls!! Reply with quote

Ok, a few months ago my heater core started leaking intermittenly. Seeing I haven't been driving it regulary, I didn't change it out immediately, and when I would drive it I would make sure there was coolant in the system. Last week I had to drive it a couple of days and after driving about 5 miles and stopping for gas on my way to work, I noticed steam coming from my radiator. I checked it out and discovered my radiator was leaking around the top. I waited for it to cool, opened the cap and saw there was still coolant in the radiator and overflow. I topped it off and drove the 5 miles back home.... very slowly and easy! The same night, after checking fluids again, I started it up and drove it to reposition it in my driveway, to work on it... no problem, started and ran fine! That night I changed the radiator and heater core, filled it back up and tryed to start it. It starts up, perfect for about 3 seconds then immediately " boggs down" runs very rough and almost stalls out, but I always cut it off before it stalls. The check engine light also comes on right before it almost stalls. I'm going to check the codes tonight , but I can not for the life of me understand what I did to cause this by changing the radiator and heater core??? I realize it might be a blown head gasket, but why did it run ok when I repositioned it in the driveway??

Any thoughts would be greatly appreciated!!!
Back to top
View user's profile Send private message
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Mon Feb 25, 2008 10:29 pm    Post subject: Reply with quote

pull the spark plugs they will be clean if you have a head gasket leak , the exhaust will also smell sweet .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Sykopro
Member


Joined: 25 Jan 2009
Location: Paso Robles, CA

PostPosted: Thu Apr 29, 2010 11:57 am    Post subject: Reply with quote

Did you figure out what caused this problem seeing as I am now having a very similiar problem?
_________________
'92 YJ 4.0 and AX15 coupled to the NP231, 5" BDS Lift, Pro Comp Steering Stabilizer, Pro Comp A/T tires on Pro Comp Rims, SYE W/Tom Woods Custom Drive Shaft.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> YJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group