Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

4wd low indicator lamp not illuminating


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
bironfish
Member


Joined: 07 Apr 2008
Location: Perth Australia

PostPosted: Mon May 19, 2008 8:42 pm    Post subject: 4wd low indicator lamp not illuminating Reply with quote

hi again,
when i bought the 96 cherokee the 4wd low indicator lamp didnt illuminate although it was in low range.. i went to dealer and a mechanic slid under the vehicle and rectified the prob in 30sec!!
It has occurred again...it goes into low range as i can tell by the gearing but the indicator lamp wont come on (4wd low)...the part time indicator is on in the low position..i have checked the shift rod connector and it is tight ..what did the mechanic do to rectify this problem so quickly...it cant be much!! please enlighten me... Embarassed
Back to top
View user's profile Send private message
kaos
Member


Joined: 10 Jan 2006
Location: Iceland

PostPosted: Tue May 20, 2008 1:16 am    Post subject: Reply with quote

He probably just unplugged and replugged the connector on the T-case mode switch, possibly squirting some contact cleaner in it.

Other possibilities:
-Burnt out bulb in the indicator.
-Misadjustment or wear in the shift linkage, so that while the T-case does go into low range, it doesnt' quite reach far enough to activate the switch. (Not actually sure whether this is possible, but might be worth checking.)
-Bad connection somewhere in the circuit.

--
Best regards,
Kári
Back to top
View user's profile Send private message Visit poster's website
bironfish
Member


Joined: 07 Apr 2008
Location: Perth Australia

PostPosted: Tue May 20, 2008 1:57 am    Post subject: Reply with quote

thankyou,,,
as i have stated i thought it just wasnt going in far enough for the light to illuminate so i tried the adjustment but no good... i think i may try to unplug and lubricate the plug thank you sir..as far as the globe goes ..if i had no indicator at all i would agree ,,but the part time is on so i will try what you sudggested ...thanks again
Back to top
View user's profile Send private message
kaos
Member


Joined: 10 Jan 2006
Location: Iceland

PostPosted: Wed May 21, 2008 1:27 am    Post subject: Reply with quote

Quote:
as far as the globe goes ..if i had no indicator at all i would agree ,,but the part time is on


The 4wd low indicator has it's own seperate bulb, so this is still a possibility.

--
Best regards,
Kári
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group