Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Stalling only in reverse???


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
Gearhead41987
Member


Joined: 07 Apr 2008

PostPosted: Tue Jun 10, 2008 10:26 am    Post subject: Stalling only in reverse??? Reply with quote

Hi All,
I'm a pretty good mechanic, but I'm new to Jeeps and the quirks that they have...
I have a '96 Cherokee sport, 3" lift and 31-10.50 tires. My motor blew up right after I bought it, so I had it replaced with the motor from a 97 Wrangler. It has been running GREAT. No smoke, blowby, noises, or oil burn.
However, I decided to run some fuel system treatment through it. I put it in a full tank, and last night (by then I was on 1\4 tank) When I was driving on the interstate (about 70mph) It would buck like the motor died, then came back and ran fine... It did this a few times randomly, so I slowed down a little, but it still did it randomly. I went to the pub, had a pint, and then went back to my jeep and when I cranked it up, it died within three seconds, cranked right back up then did the same thing again. The third time it stayed running fine. But when I put it in reverse It dies instantly. Like I turned the ignition switch off. Cranks right back up. If I put it in drive it runs fine. But thus far I have yet to get it to stay running in reverse. even if I let it roll backwards on a hill then put it in reverse so the motor doesn't have to slow down. If I feather the throttle, I can make it keep running, but it bucks and you can't get anywhere. It seriously feels just like It would if I were to turn the switch on and off. I'm going to replace the fuel filter today, and I'll clean the IAC valve tonight, but I'm almost thinking electrical.... But everything still works with the ignition still on and the gear selector in reverse. So I don't really know... Any suggestions? Cause I can't come up with a good reason for it to start this all of a sudden...
Back to top
View user's profile Send private message
2bucks
Member


Joined: 02 Jul 2006
Location: New Hampshire

PostPosted: Wed Jun 11, 2008 3:42 am    Post subject: Reply with quote

Check for frayed wire(s) on crank shaft position sensor.
Back to top
View user's profile Send private message
Gearhead41987
Member


Joined: 07 Apr 2008

PostPosted: Wed Jun 11, 2008 10:28 am    Post subject: Reply with quote

It was a binding torque converter.

I have had to follow up behind the morons that put my engine in.
Again.
They didn't tighten the transmission bolts down, and aparently they had worked themselves about 2 turns out. Enough to give me about a 1/4 inch gap between the bell housing and the engine block. Letting the engine shift slightly when it was put in reverse and binding the converter.

I just happened to notice when I had the hood open and blipped the throttle after I cleaned the intake. I saw the motor move and the transmission stay still. Scary huh?
Back to top
View user's profile Send private message
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Wed Jun 11, 2008 7:08 pm    Post subject: Reply with quote

seen that before in a Cherokee actually . never touched from factory , it just worked loose . made a really bad noise when you hit a speed bump .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Gearhead41987
Member


Joined: 07 Apr 2008

PostPosted: Thu Jun 12, 2008 4:01 am    Post subject: Reply with quote

Brad The Best wrote:
seen that before in a Cherokee actually . never touched from factory , it just worked loose . made a really bad noise when you hit a speed bump .


Mine would make a noise if you accelerated and it shifted from 4th to 3rd.

I think the flywheel teeth were barely scrubbing the bellhousing....
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group