Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

wont START!!


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
RCJP
Member


Joined: 16 Aug 2007

PostPosted: Fri Jul 04, 2008 8:51 am    Post subject: wont START!! Reply with quote

Hi to all

My Grand cherokee laredo 1998, 6L) would not start, checked the fuel pump and its OK battery is OK, a couple of times it starts for like a second and shuts off. I decided to diconect the battery and re-conected, and after that the car started again.

WHAT causes this?

than you
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Fri Jul 04, 2008 8:59 am    Post subject: Reply with quote

Is the Jeep running, or is it still having problems?
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
RCJP
Member


Joined: 16 Aug 2007

PostPosted: Fri Jul 04, 2008 9:13 am    Post subject: Reply with quote

still runnig but some times sounds like if it was shoking i turn it off and then turn it back on. and then its ok
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Fri Jul 04, 2008 9:38 am    Post subject: Reply with quote

You should clean the IAC, it might help.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
RCJP
Member


Joined: 16 Aug 2007

PostPosted: Fri Jul 04, 2008 10:10 am    Post subject: Reply with quote

Thank you. lets see what the guy from the shops tells me later tonight
Back to top
View user's profile Send private message
EYESIC
Member


Joined: 21 Sep 2007
Location: ARIZONA

PostPosted: Fri Jul 18, 2008 9:21 am    Post subject: crank shaft sensor? Reply with quote

my 93 zj was doing this to me then it wouldnt start at all, i changed the crank shaft sensor and it worked, for some reason they go bad frequently on all cherokees grand or squared...
Back to top
View user's profile Send private message MSN Messenger
RCJP
Member


Joined: 16 Aug 2007

PostPosted: Mon Jul 21, 2008 12:17 pm    Post subject: Reply with quote

Hi thank you for the replys.

i got it starting by disconecting and reconecting the Positive lead of the battery, i friend told to do this so that the PCM would reset and it worked, but it is still hard to start I guess i'll need to change the crank position sensor.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group