Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

1996 Jeep Grand Cherokee - Starting Issue/Running Issue


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
dacotua
Member


Joined: 01 Aug 2008

PostPosted: Fri Aug 01, 2008 12:44 pm    Post subject: 1996 Jeep Grand Cherokee - Starting Issue/Running Issue Reply with quote

I recently purchased a 1996 Jeep Grand Cherokee for my hunting vehicle/backup vehicle. (4.0L Inline Six)

The vehicle worked fine for about a week. Then it developed a problem with starting.

If I remove the air inlet tube and pour gas down the throttlebody, I can get it to start.

Sometimes it runs fine and others it runs terrible.

I ended up putting a fuel pressure gauge on the fuel rail and it reads 20 psi. Since its a direct feed system, I assume the Fuel pressure regulator is in the tank with the pump.

I'm not a jeep guy, I've worked on a lot of fords and some chevy's. I assume either my regulator or the fuel pump just took a dump. However since I can not access the regulator to test it, with the truck running, what should the fuel pressure at the fuel rail be while the truck is running. All the other vehicles I've owned, I would unplug the vaccum to the regulator to test. I can't do this to this vehicle, so wonder what the pressure should be before I just go out and replace the pump unit.
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Fri Aug 01, 2008 6:46 pm    Post subject: Reply with quote

37-41 psi. On a 96 the regulator is in the tank with the fuel pump. I would install a new pump.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
dacotua
Member


Joined: 01 Aug 2008

PostPosted: Sat Aug 02, 2008 4:31 pm    Post subject: Reply with quote

I removed the filter, and it wasn't plugged. Dropped the tank and removed the pump. Hooked the power to the pump and it just doesn't run strong enough. Looks like Monday I'll get a new pump from the Jeep Dealer (I have a friend who works for a dealer and got quoted 250 for a new one.).

We'll find out on tuesday or so if it fixes my issues (I think it will)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group