Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bad Sounds with my RE 4.5 SF


 
Post new topic   Reply to topic     Forum Index -> Suspension, Steering & Tires
View previous topic :: View next topic  
Author Message
quadna71
Member


Joined: 02 Jan 2004
Location: Delaware

PostPosted: Wed Jan 07, 2004 2:19 pm    Post subject: Bad Sounds with my RE 4.5 SF Reply with quote

okay...question for anyone running a similar lift to mine.

i'm getting some strange sounds coming from the drivers side rear corner of my jeep. at first i thought it was my tire carrier just bouncing some when i was hitting bumps. but i tightened it all down last night and also pulled off my spare so that the inertial bouncing would be lessened. still clunks pretty hard. i've checked upper and lower control arms at each end, the trackbar, top and bottom of the shock, the swaybar link, and even the lugnuts just in case - everything is tight and torqued properly. i can jump up and down on the bumper and hear something...but hard to locate on my own. any ideas?

i called rubicon today and queried them about the shocks. i had cross-referenced the shocks that they supplied with the lift (doetsche tech 3k's) with doetsche tech's website...the shocks that the website recommended for a tj w/4.5" lift aren't the ones that rubicon included. when i mentioned that to the tech rep he said that he was aware of that and that after realworld testing had changed things around so that they worked better for tj's. he also said that it was the same shock configuration that they've been running for years now with no complaints. but - then he immediately asked if by chance i had inadvertantly put the fronts in back and the backs in front. hmph - guess he hasn't noticed that they are different. "tech support"

anyways, the only thing i haven't tried yet is to pull all the mounting bolts on the control arms to check and see if i accidentally put the wrong bolt on somewhere. you know - like the shank's diameter is too small for the rod end that it goes through...or something to that effect. let me know if you have any ideas - thanks!
chris
_________________
2003 TJ Sport
Back to top
View user's profile Send private message Send e-mail
Code3TJ
Hacker
Hacker


Joined: 01 Jan 2004
Location: Uzbekistan

PostPosted: Wed Jan 07, 2004 2:23 pm    Post subject: Reply with quote

If nothing else, I had a clunk that I finally traced to one of the rear body mounts. Tightened it up and all was well again. How are the bushings on the shocks?
_________________
Nothing to see here.
Back to top
View user's profile Send private message
quadna71
Member


Joined: 02 Jan 2004
Location: Delaware

PostPosted: Wed Jan 07, 2004 3:07 pm    Post subject: Reply with quote

brand new bushings - put the DT3000's on with the lift. and i put bar pin eliminators on too so there's no chance of them just sliding around. everything is still tight - i'm pretty much drawing a blank. oh, and i just installed my rear shaft finally (it came via ups today from TW). just a hair of vibes on accel...quiet on decel. time to rotate the UCA's. thanks for the ideas...keep 'em coming.
chris

okay...checked the body mounts - all 11 of them. nothing there - all were tight. i pulled off the frame ends of the upper control arms to shorten them a hair - and the bolt's shank seems to have a "little" slop within the eyebolt of the control arm....follow me anyone? i'm thinking of going and getting replacement bolts that are a snug fit within the eyebolts in the morning. but in the meantime i'll pull all the rest of the control arms (one at a time of course!) to see if i can find one that is like super loose. wish me luck - i need to quiet this thing down before PAP on saturday! Sad

(i'm heading down to double check the body mounts right this second)
_________________
2003 TJ Sport
Back to top
View user's profile Send private message Send e-mail
Black2001TJ
Leopard Skin
Leopard Skin


Joined: 03 Jan 2004

PostPosted: Sun Jan 25, 2004 7:13 pm    Post subject: Reply with quote

How's this going chris? If it's any conselation, I get all kinds of noise from my RE 3.5" SF.. Have you seen if your getting contact on the rear trackbar with the gas tank skid on accel? I know your kit comes with a new tbar and bracket that's supposed to prevent that, but who knows.

Good luck!
_________________
Just damn happy to have my Jeep back, it's been a long time!
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Suspension, Steering & Tires All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group