Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

zero oil pressure for first 2 seconds after start-up


 
Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message
BlackJeepoftheFamily
Member


Joined: 12 Aug 2006
Location: Southern MN

PostPosted: Mon Dec 28, 2009 6:11 am    Post subject: zero oil pressure for first 2 seconds after start-up Reply with quote

I have a 99 Sahara with the 4.0L engine. I just replaced the oil pump last fall. Now when I start the engine, I can count "one-thousand-one, one-thousand-two" before the oil pressure starts to rise. This is only after the engine sits for awhile. On a warm start-up the pressure rises instantly.

Can anyone with a 97-00 4.0L TJ tell me if this 2 second delay is normal? Newer (01-present) Jeeps have different pressure sending units so I have nothing to compare with. I can't remember what my 99 did before I changed the oil pump.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group