Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

2000 Wrangler 4.0 troubnle code P1899


 
Post new topic   Reply to topic     Forum Index -> TJ Forum
View previous topic :: View next topic  
Author Message
Raybon1
Member


Joined: 16 Jun 2010

PostPosted: Wed Jun 16, 2010 7:04 pm    Post subject: 2000 Wrangler 4.0 troubnle code P1899 Reply with quote

I have a 2000 jeep wrangler with a 4.0 yesterday I was driving and the engine started running rough no noises or bang I slowed down and it felt as if it was running on only 4 cylinders so i limped it home and checked for spark well i had a couple of bad plugs so i replaced all the spark plugs and now i checked the codes and I got a P1899 so I ordered a new sensor but i am not sure if this will fix it The jeep will start and seems to idle good not great still has a miss and when you start off it chugs and then takes off like it is suppose to. when you come to a stop it will idle for a few seconds and then just die or just about die the some thing kicks in and revs the engine and then returns back to a normal idle and then will runn again for a few seconds and either repeat what i just said or just dies. It will crank right back up but still doing the same thing the only code I got was a P1899 is there anything else I should check. like maybe the coil pack or some other sensor what will cause it to sit there and idle and then just shut off anyone know it was running perfect yesterday and I was driving down the road when this started happening on a nice sunny day after driving 60 miles . anyone have any suggestions please let me know Thanks.
Back to top
View user's profile Send private message Send e-mail
Raybon1
Member


Joined: 16 Jun 2010

PostPosted: Thu Jun 17, 2010 4:06 pm    Post subject: jeep trouble code P1899 Reply with quote

Well I changed the park neutral switch it didnt make it run any different when the jeep is cold and you start it it runs great but only for about a minute then it just shuts off if you hold it to about 1500 rpm it is steady no hesitation or missing but when it goes back tio idle when it heats up the idle is lower than normal and it will run for a minute and just shut off again. does anyone have a suggestion as to what I should check next when it is cold it idles fine but only for a minute and then just dies. I could really use some suggestions on what to check.
Back to top
View user's profile Send private message Send e-mail
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Fri Jun 18, 2010 8:57 am    Post subject: Reply with quote

Check out the IAC valve.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> TJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group