Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Sorry for the long post but is this an issue?

Post new topic   Reply to topic     Forum Index -> Drivetrain
View previous topic :: View next topic  
Author Message

Joined: 08 Jul 2005
Location: Harrisonburg, VA

PostPosted: Sun Nov 26, 2006 4:34 pm    Post subject: Sorry for the long post but is this an issue? Reply with quote

Since this has to do with obd 1 codes I guess I will put this here. Here it goes....

The specs for my jeep are in my sig, please forgive me for not listing them here. Just got back from a 3 hour (about 6 hours round trip) ride to snowshoe to go snowboarding, when I was on the way back towards the end of the drive my check engine light came on. This has happened before when I have been driving but this time I was able to get the codes off it. Does anyone know what will cause the following codes:

12 Battery or computer recently disconnected
-low battery?-

17 Engine stays cool too long (bad thermostat or coolant sensor?)
-I didn't even know it was an issue to stay cool to long-

Now given that I had been up since 5am and I just got home, I might have miss counted the blinks but I got a 32. The 32 that is under the obd post does not seem to cover the '94 model year. But I swear we counted it right.

I was playing music the whole way with a 720 watt amp (although I'm running only one 12" sub so I would imagine that the drain would be half that at peak). When the check engine light comes on I can turn off my jeep then instantly turn it back on an the check engine light will go out. I always thought they would stay on till cleared.

But at any rate thats what I've got. Is there something really wrong or is my problem a dying battery? Also I don't think my alternator is standard, Its a japanese make I think and I think the label says it puts out 90 amps. Will get a pic if you want to see it.

Thanks for reading and any help you can give.
'94 Grand 5.2L
2" budget boost
31" mud kings
Flowmaster 50
Rusty's air tube
Rusty's steering stabilizer
AEM throttle body spacer
120 amp alternator upgrade
Rusty's Tie Rod Conversion
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Drivetrain All times are GMT - 8 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Visit for write-ups, forums and clubs

Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC. is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group