Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Weird start up noise


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
94BGCherokee
Member


Joined: 22 Jun 2006
Location: Saint Louis, MO

PostPosted: Sun Feb 11, 2007 12:34 am    Post subject: Weird start up noise Reply with quote

94 cherokee 168000 miles. When i start the car whent its astro cold, like 20 degrees or below, I get this loud wiining sound from under the hood, almost sounds like a whirring. It is intermittent when its cold when i let it warm up, i can hear it inside my house. Im thiniking its p/s considering the water pump is new, the alternator charge is fine, and the a\c sounds great(stethescope). and since its hard to turn the wheel when you first start it, thats what makes me think thats what it is. Not like its getting worse just an annoying sound. Any Ideas if it is P/S, just wait till it goes out, is there any maintainence I can do on it? Idler pulley has been replaced as well. Belt is new, its not slipping ive checked that. P/s it not leaking and its full, so i have no idea. Input and help is greatly appreciated, thanks for looking.
Back to top
View user's profile Send private message Send e-mail AIM Address
JeepinNH
Member


Joined: 13 Sep 2005
Location: New Hampshire

PostPosted: Sun Feb 11, 2007 11:16 am    Post subject: noise Reply with quote

Sounds like the p/s pump to me. I had an 86 that made the same noise. Sometimes the fluid would spray out the cap. I changed pretty much everything in the p/s line and it still happened so I just ignored it. Maybe I should have stayed away from rebuilds.
_________________
Mike

Present: 99 Cherokee
Past: 86, 87 Cherokee; 94 Grand Cherokee
Back to top
View user's profile Send private message
ehirner
Moderator
Moderator


Joined: 01 Jan 2004
Location: Eastern PA

PostPosted: Sun Feb 11, 2007 1:23 pm    Post subject: Reply with quote

Do you have enough tension on your serpentine belt?
_________________
04 Unlimited
Back to top
View user's profile Send private message AIM Address
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Feb 11, 2007 4:07 pm    Post subject: Reply with quote

mine does that as well its just the serpentine belt ( it's adjusted properly i used a fancy tool for it ) im sure it would go away with a new belt in my case. i have just learned to live with it .

check your belt out first . condition and how tight it is
Back to top
View user's profile Send private message Send e-mail MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group