Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

PO522 oil pressure sensor/switch low voltage code


 
Post new topic   Reply to topic     Forum Index -> Liberty Forum
View previous topic :: View next topic  
Author Message
jeepdaddy65
Member


Joined: 04 May 2008
Location: Grafton, Ohio

PostPosted: Wed Oct 22, 2008 12:45 pm    Post subject: PO522 oil pressure sensor/switch low voltage code Reply with quote

I have a 05 Liberty with a 3.7L. On the first start up of the day my oil light comes on and stays on and it throws this PO522 code. If I shut it down and restart it goes away, and doesn't happen anymore until it sits awhile or overnight. I don't know if its the oil pressure sending unit or an electrical problem maybe the oil pump is going bad. I'm new to this forum and appreciate any help. Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Liberty Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group