Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

i need help with idle prob


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
b_radley_05
Member


Joined: 25 Jul 2007
Location: Spanish fork, tah

PostPosted: Wed Sep 05, 2007 6:19 pm    Post subject: i need help with idle prob Reply with quote

ok first off i am new here. this forum is great it helps tons. ok i have a 1990 xj. i got it for $500 so it has lots of problems. the biggest of witch at the moment is it has a problem idling and stalling. it idles fine when i start it but if i push the gas a little and let of it will die and after it gets werm it idles high and sometimes it backfires and it surges when it idles. any help would be great. thanks
Back to top
View user's profile Send private message
c130herc
Member


Joined: 11 Oct 2006
Location: North Texas

PostPosted: Thu Sep 06, 2007 3:32 am    Post subject: Reply with quote

Could be a map sensor, it is in the engine bay on the firewall almost center up closer to the hood. It should have a vacuum line going to it and an electrical plug. If you know someone with an XJ you could borrow his to trouble shoot it.
_________________
88 XJ - 35" tires, T&T LA, D44/F9 Other mods
Back to top
View user's profile Send private message
b_radley_05
Member


Joined: 25 Jul 2007
Location: Spanish fork, tah

PostPosted: Thu Sep 06, 2007 2:40 pm    Post subject: Reply with quote

ok i will try that thanks!
Back to top
View user's profile Send private message
88WOWJ
Member


Joined: 12 Aug 2006
Location: Hinesville Ga

PostPosted: Sat Sep 08, 2007 5:29 am    Post subject: Help with idle problem Reply with quote

Its your TPS. Throttle Position sensor.
The semsor cant see idle positon. So when you accelerate the engine floods or starves and stalls. Disconnect the TPS and see if the same thing happens.
_________________
1988 Wagoneer Limited XJ Tellico Tested
Rocklizards panels, Tomken rear bumper and front Tow brackets, Rocket air intake, 2 inch lift,
30x950x15, 1991 coolant system with electric fans, 8,000 mile marker winch
1991 Cherokee Limited
Back to top
View user's profile Send private message Send e-mail
b_radley_05
Member


Joined: 25 Jul 2007
Location: Spanish fork, tah

PostPosted: Sun Sep 09, 2007 9:02 pm    Post subject: Reply with quote

you are right thanks. so i disconected it and it worked does that mean it is bad o it just needs to be ajusted. i know it easy to take of but how hard is it to adjust?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group