Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

My 94 XJ won't blow heat....please help

Goto page 1, 2  Next
 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
s1deout
Member


Joined: 13 May 2007

PostPosted: Mon Dec 24, 2007 7:05 am    Post subject: My 94 XJ won't blow heat....please help Reply with quote

I have a 1994 2 Dr Cherokee XJ 4x4 w/ Manual Tranny. A couple of months ago the low and medium settings stop working to blow heat. It didn't seem to increase the amount of heat it blew from low to medium, but the high setting still worked well. Now the high setting doesn't work either. I can feel hot air coming through but not enough to defrost the windshield or provide a comfortable drive when it's cold out.

Any ideas??? Thanks in advance....
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Mon Dec 24, 2007 8:55 am    Post subject: Reply with quote

The blower motor may be shot! I would try to run some wires to it from the battery to see if it's working.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
s1deout
Member


Joined: 13 May 2007

PostPosted: Wed Dec 26, 2007 5:41 am    Post subject: Blower Motor? Reply with quote

I will see if I can get in there and check it.

Would this be the part that would need replaced?

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&ih=014&sspagename=STRK%3AMEWA%3AIT&viewitem=&item=330199817658&rd=1

My A/C does not blow cold air either, but I think its because there is a hole in the line from the compressor??

Thanks for your help.
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Wed Dec 26, 2007 10:47 am    Post subject: Reply with quote

Yes, that's the motor!
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
2wd lame-o
Member


Joined: 28 Dec 2007
Location: Los Angeles, CA

PostPosted: Sun Dec 30, 2007 10:41 am    Post subject: ohh electrical Reply with quote

If you don't have one already, get a test light (they are cheap) always test the light first on the battery. One of the wires going to the motor should be hot when the fan switch is on. more than a few times its a silly wire short than the whole motor. also test the fuse for the fan. I have found stuff that previous owners and mechanics simply forgot to reconnect after working on a related part. good luck
Back to top
View user's profile Send private message
s1deout
Member


Joined: 13 May 2007

PostPosted: Wed Jan 09, 2008 6:54 am    Post subject: A/C & Heater Blower Motor Reply with quote

I purchased a blower motor but apparently it must have the wrong one. Because the connector doesn't fit the existing one.

Will this one fit?

http://www.thepartsbin.com/catalog/products.php?year=1994&make_text=jeep&model_text=cherokee&category=climate_control&subcategory=blower_motor&part_name=a-fs-c_blower_motor

I'm trying to locate where the wire connects to the battery but it runs through a piece of plastic condiut. I'm pretty sure that the motor is shot.

What controls the fan speed since that wasn't working either?? Only blew heat on low and high settings before the motor went out.

Thanks!
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Wed Jan 09, 2008 10:15 am    Post subject: Reply with quote

You can run a jumper wires from the connector on the motor, to the battery, to test it. You can use the new motor you have if it mounts the same and has the same wires, just cut off the connectors and connect the wires. The motor in the ad should also work.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
s1deout
Member


Joined: 13 May 2007

PostPosted: Wed Jan 09, 2008 5:53 pm    Post subject: Blower Motor Resistor Reply with quote

I haven't tested the wires yet but will once I can get a tester.

I have read that the blower motor resistor might be an issue if the fan speeds do not function correctly. Can anyone tell me where to locate this and what the part looks like??

1994 Jeep Cherokee XJ / 2DR / Manual

Thanks!
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Wed Jan 09, 2008 10:09 pm    Post subject: Re: Blower Motor Resistor Reply with quote

s1deout wrote:
I haven't tested the wires yet but will once I can get a tester.


I wasn't suggesting to test the wires. I'm talking about running jumper wires from the blower motor to the battery. Take a couple pieces of wire, attach them to the terminals in the connector on the motor, then run one wire to the positive on the battery and one to the negative. This will give it 12 volts directly. If the motor doesn't start, it's bad.
Here's a pic of the resistor location.



_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
s1deout
Member


Joined: 13 May 2007

PostPosted: Thu Jan 10, 2008 2:14 pm    Post subject: Cannot detach hose from blower motor Reply with quote

Thanks for the diagram. It helped a bunch. I was able to test the wires and they are working, so it seems that the blower motor is dead.

I replaced the blower motor resistor with the new one I received today.

I have all of the screws out to take the blower motor out now, but there is a 1" hose coming out of the bottom of the motor and it goes back into the body. Is this a drain hose?? And how in the world do you get this thing off??

If I do manage to get it off...how does it reattach to the new motor???

Thanks so much for your help.[/img]
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Thu Jan 10, 2008 7:37 pm    Post subject: Re: Cannot detach hose from blower motor Reply with quote

You should be able to pull off the hose and swap it over to the new one. Then again, it might not attach to the new motor at all. Mr. Green
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
Toliver09
Member


Joined: 16 Oct 2007
Location: Central Illinois

PostPosted: Thu Jan 10, 2008 8:18 pm    Post subject: Reply with quote

im gunna vote amc as one of the top helping hands the XJ forum has Smile always helping people, someone should reward you with a PhD in Jeepinology
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
s1deout
Member


Joined: 13 May 2007

PostPosted: Fri Jan 11, 2008 4:44 am    Post subject: Hose Reply with quote

Maybe i'm just too weak to get this God forsaken hose off the old motor, but i've been pulling on it for hours now.

I'll have to devote most of my Saturday to this task. On the new motor there is a spot to attach this hose.

Thanks again for your help!!
Back to top
View user's profile Send private message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Fri Jan 11, 2008 8:38 am    Post subject: Reply with quote

I don't know if you tried already, but a squirt of wd-40 should help that hose come right off!

You're Welcome!!!

_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
s1deout
Member


Joined: 13 May 2007

PostPosted: Fri Jan 11, 2008 7:47 pm    Post subject: Now i'm getting frustrated Reply with quote

I was able to get the blower motor out after cutting the edge of the hose from it. The hose was apparently glued on which was causing the trouble.

The fun doesn't end there though. I hooked up the new motor to discover that it doesn't run either. So I attached the new motor straight to the battery and it does run. The old motor does not run straight from the battery...what a coincidence.

I'm thinking it is either the connector on blower motor or the connector that goes to the battery. What would be the best way to test this???

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group