Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

i need help with my 90 cherokee


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
b_radley_05
Member


Joined: 25 Jul 2007
Location: Spanish fork, tah

PostPosted: Wed Jan 30, 2008 5:06 pm    Post subject: i need help with my 90 cherokee Reply with quote

hello everyone i am back and i have lots of questions but first i just want to say i rebuilt my motor all bye myself and it runs much better now, ok i asked a while ago a idling and stalling problems. well i figured out thatr my idling prob was because of a blown head gasket. so after i rebuilt the engine it fixed that prob but it still stalls Sad so i know its not a vacume prob i have swaped out the idler moter with two different ones but they were both used and it didnt fix it. i changed the tps and it didnt fix it so any ideas????? there is a canister looking thing with a cable coming out of it that conects to the throttle. i thought may be that might have something to do with it but i dont know.
Back to top
View user's profile Send private message
kaos
Member


Joined: 10 Jan 2006
Location: Iceland

PostPosted: Thu Jan 31, 2008 12:21 am    Post subject: Reply with quote

The canister thing is the cruise control actuator. You can try unhooking that cable if you wish, but I rather doubt that that is your problem. Have you checked for trouble codes? There might be some logged, even though the check engine light does not light.

--
Best regards,
Kári
Back to top
View user's profile Send private message Visit poster's website
c130herc
Member


Joined: 11 Oct 2006
Location: North Texas

PostPosted: Fri Feb 01, 2008 8:22 am    Post subject: Reply with quote

Could be either your MAP sensor, its on the firewall near center, above the valve cover, has a green electrical plug and a vacume line going to it.
Also could be the O2 sensor on the exhaust header. To check the O2 sensor just unplug it. It will make the motor run rich but should not stall.
The MAP can be ohmed out. I keep a spare good one around from a junk yard xj for trouble shooting.
Go to this link, it should help.
http://www.lunghd.com/Tech_Articles/Engine/Basic_Sensors_Diagnostics.htm
_________________
88 XJ - 35" tires, T&T LA, D44/F9 Other mods
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group