Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

1985 wont start, has spark and smell gas!!!


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Mon Jan 28, 2008 1:11 pm    Post subject: 1985 wont start, has spark and smell gas!!! Reply with quote

i just got a 1985 jeep cherokee, the thing wont start for the life of me, i check the spark it has a good spark. and i can smell gas by the carb!!
if anyone could help that woulf be great!!
Back to top
View user's profile Send private message Send e-mail AIM Address
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Mon Jan 28, 2008 1:37 pm    Post subject: Reply with quote

oh and it is the 2.8 v-6
Back to top
View user's profile Send private message Send e-mail AIM Address
Toliver09
Member


Joined: 16 Oct 2007
Location: Central Illinois

PostPosted: Mon Jan 28, 2008 4:03 pm    Post subject: Reply with quote

good spark meaning a strong blue spark or a yellowish orange spark? Are the plug wires lined up correctly? is the motor even cranking? if you have been stomping the gas to try to start it it may be flooded. The starter motor may not be cranking fast enough, it's hard to say. try spraying a small amount of ether into the carb, if it starts or sputters you arent getting enough gas to the carb. I would recommend taking the carb off and cleaning it out through and through, make sure the floats are working correctly and all that jazz.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Mon Jan 28, 2008 6:14 pm    Post subject: Reply with quote

use brakes cleaner instead of ether , i have seen way to many gas engines that are fucked sideways excuse my language ,from people shooting starting fluid in them .

wd-40 will also work .


when was the last time it ran ?
Back to top
View user's profile Send private message Send e-mail MSN Messenger
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Mon Jan 28, 2008 6:35 pm    Post subject: Reply with quote

the spark is yellow i am going to go out and get new plugs and wire tomarrow, the engine cranks strong and thats when i get the gas smell. i dont slam on the gas.
Back to top
View user's profile Send private message Send e-mail AIM Address
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Mon Jan 28, 2008 6:37 pm    Post subject: Reply with quote

it ran and drove a month ago. well thats what i was told!!
Back to top
View user's profile Send private message Send e-mail AIM Address
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Mon Jan 28, 2008 9:05 pm    Post subject: Reply with quote

good idea on replacing plugs n wires . i would get a distributor cap and rotor as well
Back to top
View user's profile Send private message Send e-mail MSN Messenger
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Tue Jan 29, 2008 11:47 am    Post subject: Reply with quote

ya i did all that!! sounds the same i think either i have a choke problem for a crab, does any one know where i can find a good diagram for the carb rebuild and something on the choke???
Back to top
View user's profile Send private message Send e-mail AIM Address
Toliver09
Member


Joined: 16 Oct 2007
Location: Central Illinois

PostPosted: Tue Jan 29, 2008 2:46 pm    Post subject: Reply with quote

while your at it... replace the coil. You can get new rotor/cap/wires/plugs, but none of it will matter if your coil is weak. Hopefully that will solve the no start problem
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Tue Jan 29, 2008 4:55 pm    Post subject: Reply with quote

i will try that!! another question is the person that had the truck before me took all the vacum lines out is that possible the reason if so does any one know where i can get a vacum line diagram???
Back to top
View user's profile Send private message Send e-mail AIM Address
Toliver09
Member


Joined: 16 Oct 2007
Location: Central Illinois

PostPosted: Tue Jan 29, 2008 7:39 pm    Post subject: Reply with quote

hmm... no vacuum could definately have something to do with it considering almost every part of the motor has something involving vacuum. I would do some searching or go to your nearest auto shop and get a haynes manual
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Wed Jan 30, 2008 9:39 am    Post subject: Reply with quote

When you are trying to start it, is there anything at all coming out of the tailpipe, even a smell? Right after cranking to start, what do the plugs look and smell like? Are you sure you're getting fuel to the combustion chamber?
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Sun Feb 03, 2008 8:37 am    Post subject: Reply with quote

theres nothing comeing out the pipes but a smelll! i found out my fireing order was off, i fixed that and now i notice my rotor is cracked and has corroutionon on it connntectors!! so i am going to replace that today and let you guys know how it turns out!!
Back to top
View user's profile Send private message Send e-mail AIM Address
1984cherokee
Member


Joined: 28 Jan 2008
Location: il

PostPosted: Wed Feb 06, 2008 8:51 pm    Post subject: Reply with quote

ya it ended up being the guy that had it before me moved the distributor, so i had to fix that and then she started right up no problems, runs good.
Back to top
View user's profile Send private message Send e-mail AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group