Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

4.0L Runs Cold?


 
Post new topic   Reply to topic     Forum Index -> Drivetrain
View previous topic :: View next topic  
Author Message
johnnykomac
Member


Joined: 28 Feb 2008
Location: Oahu, Hawaii

PostPosted: Sat Mar 08, 2008 12:20 am    Post subject: 4.0L Runs Cold? Reply with quote

My 4.0L is running cold. The temp guage never reaches half way.

Also, I'm only getting 14.5MPG.

Whats going on?!?!
Back to top
View user's profile Send private message
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Sat Mar 08, 2008 6:46 am    Post subject: Reply with quote

What temp is it reading?

It sounds like a bad temp sensor. That would cause it to send the incorrect engine temp to the ECU, and the ECU would then run the engine rich in an attempt to bring the temp up. That would explain why the MPG's are so low.
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
hutchman
Captain Kirk
Captain Kirk


Joined: 07 Feb 2007
Location: Kennewick, WA

PostPosted: Sat Mar 08, 2008 9:03 am    Post subject: Reply with quote

Does the heater blow really hot air or has it cooled off?

If the heater doesn't get hot chances are you have a stuck themostat.........

Just another thought.
Back to top
View user's profile Send private message
johnnykomac
Member


Joined: 28 Feb 2008
Location: Oahu, Hawaii

PostPosted: Sat Mar 08, 2008 10:39 am    Post subject: Reply with quote

When I first bought the car the temp reading was at 210 or a little higher. I changed the oil, used some lucas oil stabilizer, and made sure the coolant bottle was filled. Now, it never gets above 150 which, sounds way to low.

Wheres the temp sensor located. I thought it might be a TPS or MAF sensor and thats what could be making it run so rich.

How should I narrow down which one it is?
Back to top
View user's profile Send private message
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Sat Mar 08, 2008 12:33 pm    Post subject: Reply with quote

If the gauge is reading 150 degrees, then that's what the ECU thinks it's running at...resulting in the rich condition. The sensor is located in the thermostat housing.
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
dodger889
Member


Joined: 11 Mar 2008
Location: 48189

PostPosted: Tue Mar 18, 2008 5:43 pm    Post subject: Reply with quote

Ok if you can put your hand on top of the radator and able to hold it there for a little while then it running cold if you put your hand on the radator and it's hot where your hand feels burned by just touching it then it's running about right...
Back to top
View user's profile Send private message
TheBrat97
Member


Joined: 28 Jul 2006
Location: Dallas, TX

PostPosted: Sun Apr 20, 2008 5:06 pm    Post subject: Reply with quote

I'd have to agree with Phantum on this one. The temp sensor is inexpensive and easy to replace so it's worth a shot. Oh and don't forget to use teflon tape! Mr. Green
_________________
2005 TJ 2" Lift 33" TrXuS M/T's
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Drivetrain All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group