Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

1994 XJ Lazy Starter


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
The Jeepster
Member


Joined: 31 Mar 2008
Location: Derbyshire. U.K

PostPosted: Mon Mar 31, 2008 8:00 am    Post subject: 1994 XJ Lazy Starter Reply with quote

Hi, great forum! I'm having a little problem with my 1994 Cherokee. She's a 4 litre High Output model and normally starts up with a roar - a really head turner, but after having a electrical short and a flat battery she now starts with a whimper , almost like it will stall. The engine turns over ok and once running and warm she's fine (we had an autogas conversion so she starts on petrol but runs on LPG, so it not this) Any ideas?
Back to top
View user's profile Send private message
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Mon Mar 31, 2008 7:37 pm    Post subject: Reply with quote

battery . how long was it dead for ? thats what kills a battery . being dead for a long time , you can kill one but you have to charge it .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
The Jeepster
Member


Joined: 31 Mar 2008
Location: Derbyshire. U.K

PostPosted: Tue Apr 01, 2008 2:53 am    Post subject: Reply with quote

The battery discharged overnight. The postive earth lead connection was loose (the end came off when I took the battery leads off). It's only when she starts up on petrol when cold that it sounds lame, starting up on LPG or starting warm it's fine.
Back to top
View user's profile Send private message
jppilot61
Moderator
Moderator


Joined: 06 Mar 2004
Location: Tappahannock, VA

PostPosted: Tue Apr 01, 2008 4:16 am    Post subject: Reply with quote

Are you describing a starting problem or a Cold engine Idling problem?

Unless you know it is clean, I'd start with Cleaning the Throttle body and make sure the TPS (Throttle Position) Sensor is working correctly and possibly even the IAC Valve (Idle Air Control). Sensors were about $40 each here in US.

Cleaning the Throttle Body of probably 15+ years of gunk and shellac-like substance and changing my TPS sensor allowed my JEEP to begin starting great as opposed to only every other time of cranking it.
_________________



1992 XJ Laredo
RE6130 4.5" XJ Super-Flex Kit
RE1801 Slip Yoke Eliminator Kit NP231
Back to top
View user's profile Send private message
DavidXJ
Member


Joined: 07 Sep 2006
Location: Visalia, CA

PostPosted: Tue Apr 01, 2008 6:50 am    Post subject: Reply with quote

Cherokees will often start lame after a discharged battery. I've had to jump them a few times after a dead battery, and they don't run well until they've been running a bit (might be because the computer needs to reset?). So if your battery has been dying, that could be your problem.
Back to top
View user's profile Send private message
Toliver09
Member


Joined: 16 Oct 2007
Location: Central Illinois

PostPosted: Tue Apr 01, 2008 12:38 pm    Post subject: Reply with quote

i think this is the same problem i am having. My battery had a dead cell and I had to replace it temporarily with a smaller battery (only 280 cca) It starts, sputters and dies twice and on the 3rd start it get right up. My check engine light also came on and I havent checked codes yet, but I'm sure it has something to do with the battery, I only run 12v on the gauge
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
The Jeepster
Member


Joined: 31 Mar 2008
Location: Derbyshire. U.K

PostPosted: Wed Apr 02, 2008 10:18 am    Post subject: Reply with quote

Quote:
[i].............Cherokees will often start lame after a discharged battery. I've had to jump them a few times after a dead battery, and they don't run well until they've been running a bit (might be because the computer needs to reset?). So if your battery has been dying, that could be your problem.[/i]



Thanks. Must have been. She's back to frightening the neighbours now. Heh heh. Finger
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group