Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Injectors

Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Fri Apr 25, 2008 8:00 pm    Post subject: Reply with quote

Is the wire still plugged in?
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Fri Apr 25, 2008 9:36 pm    Post subject: Reply with quote

Which wire? All the wires that I disconnected were reconnected when I tightened things up today. Unless I missed one. What should I look for?
Back to top
View user's profile Send private message Send e-mail AIM Address
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Sat Apr 26, 2008 7:41 am    Post subject: Reply with quote

The temp sensor has one wire attached. Here are two places it could be. If not there, look on or around the thermostat housing.




Rear right corner of the valve cover!

_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Sat Apr 26, 2008 9:19 am    Post subject: Reply with quote

Would these usually just die? Before I dove into it, it was working fine. I never got close to it when I was working on it either. Is there a connector ontop of the engine somewhere? I unplugged a few connectors when I was removing the fuel rail. Would heat damage these sencors. My Jeep was just into the red before I was able to get off the freeway when everything took a dump on me.
Back to top
View user's profile Send private message Send e-mail AIM Address
Brad The Best
Member


Joined: 14 Jan 2007
Location: Kamloops B.C Canada

PostPosted: Sun Apr 27, 2008 1:44 pm    Post subject: Reply with quote

its a notorious bad connection , wiggle it and watch the gage actually work , or get a new sensor it just senses resistance to ground , they corrode and become worthless once in a while .

thing happen for no reason , don't worry .
Back to top
View user's profile Send private message Send e-mail MSN Messenger
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Sun Apr 27, 2008 7:28 pm    Post subject: Reply with quote

Is there a connection on the top f the engine? I unplugged a few of the connectors when I was replacing the injectors. I wiggled the connectors on the sensor and the gauge is still reads zero.
Back to top
View user's profile Send private message Send e-mail AIM Address
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Tue Apr 29, 2008 3:52 pm    Post subject: Reply with quote

jppilot61,
I saw in an old post that you trimmed your front fenders. i was wondering if you had any more pictures of your job. i was planning on doing the same thing.

Thanks for the help again.
Back to top
View user's profile Send private message Send e-mail AIM Address
Toliver09
Member


Joined: 16 Oct 2007
Location: Central Illinois

PostPosted: Sun May 04, 2008 7:09 pm    Post subject: Reply with quote

on my 92 the temp sensor is on the front driver side of the block right next to the thermostat housing and the temp SENDER for the gauge is on the rear top of the motor on the driver side, make sure you have the sender reconnected.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Sun May 04, 2008 9:41 pm    Post subject: Reply with quote

Toliver09, Which engine do you have? My Cherokee has the I-6.
Back to top
View user's profile Send private message Send e-mail AIM Address
kaos
Member


Joined: 10 Jan 2006
Location: Iceland

PostPosted: Mon May 05, 2008 1:45 am    Post subject: Reply with quote

I've just been having some temp gauge problems myself, and finally located the sender where Tolliver describes it. It is very easy to overlook, at least on the ZJ (haven't checked the XJ) as it is hidden behind a wiring bundle that runs alongside the valve cover. Anyway, that's where I found it; on top of the head, beside the valve cover on the drivers side, at the rear of the engine. The sensor on the thermostat housing is for the ECU. Oh, and it's the 4.0L.

--
Regards,
Kári
Back to top
View user's profile Send private message Visit poster's website
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Mon May 05, 2008 7:19 am    Post subject: Reply with quote

Unless I'm missing something, I don't see what you guys see. I have nothing connected to my thermostat. Just my upper radiator hose.
Back to top
View user's profile Send private message Send e-mail AIM Address
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Mon May 05, 2008 8:11 am    Post subject: Reply with quote

kaos wrote:
I've just been having some temp gauge problems myself, and finally located the sender where Tolliver describes it. It is very easy to overlook, at least on the ZJ (haven't checked the XJ) as it is hidden behind a wiring bundle that runs alongside the valve cover. Anyway, that's where I found it; on top of the head, beside the valve cover on the drivers side, at the rear of the engine. The sensor on the thermostat housing is for the ECU. Oh, and it's the 4.0L.

--
Regards,
Kári


The pictures I posted, are of this location!
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Mon May 05, 2008 8:29 am    Post subject: Reply with quote

Ok. Lets get this straight. Are we talking about the sensor itself, or the connector? Orandeamc13, I found the sensor with the pix you sent. They worked great. THX!!! kaos, you are refering to the connectors on top of the engine, right? I am in the proccess of uplaoding some pix for you guys to make it idiot proof for me.
Back to top
View user's profile Send private message Send e-mail AIM Address
mexirican
Member


Joined: 01 Jul 2007
Location: Mesa, AZ

PostPosted: Mon May 05, 2008 8:56 am    Post subject: Reply with quote

Ok. Here are the piks.

These are the two connectors that i disconnected when I took out my fuel rail...




This little connector is the only thing that i didn't connect. I forgot if it wasn't connected when I dove into it or if it was, and I just forgot were it goes. Rolling Eyes


Any help you guys have would be awesome.
Back to top
View user's profile Send private message Send e-mail AIM Address
kaos
Member


Joined: 10 Jan 2006
Location: Iceland

PostPosted: Mon May 05, 2008 1:53 pm    Post subject: Reply with quote

Quote:
This little connector is the only thing that i didn't connect.


Bingo! Very Happy

Look behind the wire bundle that is coming down from the firewall. The sensor should be lurking there on the corner of the head.

--
Regards,
Kári.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group