Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

stereo and dome lights out


 
Post new topic   Reply to topic     Forum Index -> YJ Forum
View previous topic :: View next topic  
Author Message
jackson
Member


Joined: 26 Jan 2008
Location: Mass

PostPosted: Fri Apr 18, 2008 9:05 pm    Post subject: stereo and dome lights out Reply with quote

I posted this in the electronic forum, but didn't get any feedback. I wired a new speaker bar in my 95YJ. After splicing the wires into the existing wiring, the stereo was working for a few minutes and then went out. Now the stereo and dome lights aren't working. The fuses in the fuse panel are good and the fuse on the stereo is good also. Any suggestions?
Back to top
View user's profile Send private message
jeepboi
Member


Joined: 07 Jul 2007
Location: Forney, Tx, Usa

PostPosted: Sat Apr 19, 2008 6:24 pm    Post subject: Reply with quote

Not sure if it's the same, but in my 96 xj I did the same and thier's a radio fuse under the dash on the drivers side you should just be able to put in a new fuse and all is well.
Back to top
View user's profile Send private message
jackson
Member


Joined: 26 Jan 2008
Location: Mass

PostPosted: Sun Apr 20, 2008 5:04 am    Post subject: fuse Reply with quote

Thanks for the reply. There isn't any fuse in the stereo spot on the fuse panel, but I changed the dome light fuse and the acc fuse. All the other fuses are fine. The stereo was working fine until I wired the speaker bar. I since disconnected the bar and the stereo and dome lights are still out. The fuse on the stereo is fine also. ????????
Back to top
View user's profile Send private message
jppilot61
Moderator
Moderator


Joined: 06 Mar 2004
Location: Tappahannock, VA

PostPosted: Sun Apr 20, 2008 6:49 am    Post subject: Reply with quote

Disconnect the connector from back of Stereo? Then see if the Dome lights work?

You may have smoked radio?

I had a radio (that still worked) but drained the battery when the ignition was off.

Was the Dome Light Circuit that had steady drain when it should not have. It was a component in Radio. I replaced radio and ALL was good again . . . .
_________________



1992 XJ Laredo
RE6130 4.5" XJ Super-Flex Kit
RE1801 Slip Yoke Eliminator Kit NP231
Back to top
View user's profile Send private message
jackson
Member


Joined: 26 Jan 2008
Location: Mass

PostPosted: Mon Apr 21, 2008 3:44 pm    Post subject: Reply with quote

Thanks, but both are still not working. All the fuses are good. I can't figure it out, any more suggestions?
Back to top
View user's profile Send private message
hutchman
Captain Kirk
Captain Kirk


Joined: 07 Feb 2007
Location: Kennewick, WA

PostPosted: Mon Apr 21, 2008 6:07 pm    Post subject: Reply with quote

There at least seems to be a common failure here, and you have looked at all the obvious causes and they seem to be OK. In the past when I have had something like this occur, I did one of two things:

1. Go over the wiring looking for faults. If this is common and you have a good source of power and the fuses are good, then you must have an open wire in the circuit. Find it and fix it.

2. If this doesn't work or you can't find the problem, I have as a last resort run a new power supply to the affected loads. This new power supply must be fused and sized like the factory original. I don't think this is the best solution, but sometimes, at least for me, it was the only thing that worked.

I wish I was a wizard so I could solve this problem for you, but I guess I'm not......
Back to top
View user's profile Send private message
jppilot61
Moderator
Moderator


Joined: 06 Mar 2004
Location: Tappahannock, VA

PostPosted: Tue Apr 22, 2008 2:26 am    Post subject: Reply with quote

Did the Radio have its own inline fuse on one of its power leads? Have you checked it? You said there wasn't a fuse in the Stereo spot? Has it ever worked before without that fuse? Very curious? I'd slap one in there so as not to discount the obvious?

You checked all fuses (under hood too?) Do you have power at the fuse block to the Dome Light Circuit? Get a multimeter (voltmeter) and a test light.

If you spliced after the inline fuse that may take out your Dome Lights and Radio?

Hard to say exactly from here but don't overlook the obvious thing you did since it worked right.

Just as Hutchman stated: Check the hot side wiring and the associated return wires as well.

Good luck!
_________________



1992 XJ Laredo
RE6130 4.5" XJ Super-Flex Kit
RE1801 Slip Yoke Eliminator Kit NP231
Back to top
View user's profile Send private message
jackson
Member


Joined: 26 Jan 2008
Location: Mass

PostPosted: Thu Apr 24, 2008 7:05 am    Post subject: Reply with quote

Thanks again, it ended up being a fuse under the hood. A 10 AMP IOD fuse. It was one I didn't check before because I didn't know what it was for.
Back to top
View user's profile Send private message
hutchman
Captain Kirk
Captain Kirk


Joined: 07 Feb 2007
Location: Kennewick, WA

PostPosted: Thu Apr 24, 2008 7:36 am    Post subject: Reply with quote

Glad you found it!
Back to top
View user's profile Send private message
jppilot61
Moderator
Moderator


Joined: 06 Mar 2004
Location: Tappahannock, VA

PostPosted: Thu Apr 24, 2008 12:42 pm    Post subject: Reply with quote

IOD = Ignition Off Drain

Very curious why you had a blown fuse there?

Maybe a miswire during stereo install?

Been there done that!

Glad you are back up and running!
Back to top
View user's profile Send private message
jackson
Member


Joined: 26 Jan 2008
Location: Mass

PostPosted: Thu Apr 24, 2008 2:11 pm    Post subject: Reply with quote

Thanks, my buddy that helped me out said I might have cut the two dome light wires together and caused it. Who knows, it's fixed now. Thanks again.
Back to top
View user's profile Send private message
benwj
Member


Joined: 01 Oct 2004
Location: Land of Sand

PostPosted: Tue Sep 23, 2008 6:56 am    Post subject: Reply with quote

Whats IOD? was my next question after this one:

Dome light power is used as battery backup power for the stereo but I must have blown the fuse while hooking it up.

Now I can't find the fuse.

It is labelled as Fuse 16 on the chiltons workshop manual.
The fuse block under the dash doesn't have a fuse 16, but it does have a fuse 5 labelled as "Dome" which ended up being something to do with the ignition.
The power dstribution box under the bonnet has a fuse 16 labelled as "IOD" but it isn't blown, and now that I know what IOD is, that doesn't sound right.

So before I start pulling the fuse blocks apart, can anyone confirm where the fuse for the dome lights is?
Back to top
View user's profile Send private message
bubbaedc
Member


Joined: 12 May 2008
Location: tucson, AZ

PostPosted: Wed Sep 24, 2008 8:16 am    Post subject: Reply with quote

im my experiance as a car installer ive found even if the radio fuse is fine, check all the fuses anyway, even if you dont think it would have anything to do with the radio, ive had door lock fuses that ran radios, you never know what the prior owner did to get teh radio working before, they could have jumpered the power wire over to almost anything else with power
_________________
'98 TJ
4" Rough Country S lift 1" daystar BL
dana 60/44 combo
39.5x16.50R16 pitbull rocker extremes
Homemade Bumpers and rock sliders
check us out at www.tucsonoffroad.net
Back to top
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
benwj
Member


Joined: 01 Oct 2004
Location: Land of Sand

PostPosted: Wed Sep 24, 2008 11:02 pm    Post subject: Reply with quote

All of the fuses checked out OK.

Anyone got a decent electrical diagram I can look at?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> YJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group