Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

'87 Comanche clutch question


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
Conejo
Member


Joined: 21 Apr 2008
Location: Austin, TX

PostPosted: Mon Apr 21, 2008 8:13 pm    Post subject: '87 Comanche clutch question Reply with quote

Hey guys!

I just bought an '87 longbed 4x4 Jeep Comanche, i'm pretty excited about it.

But the prominent issue at hand is the clutch is not working properly. I only drove it briefly today, but heres the working description as of now:

I can depress the clutch which has what I would call normal tension on it but once I shift into gear and release the clutch it takes it awhile to really "catch" gear and even at that, it doesn't catch completely. It feels like when you halfway hold the clutch in while at speed so you're getting about half as much hook-up and power as it feels like you should be getting.

Any ideas?

Thanks much guys and I'm sure glad I found yall! I'll have pics up soon enough.

Conejo
Back to top
View user's profile Send private message
djgrayxj
Member


Joined: 26 Sep 2007
Location: Southern California

PostPosted: Tue Apr 22, 2008 5:12 am    Post subject: Reply with quote

What engine do you have [plus mileage] and do you have oil leaking from the bell housing? 4.0 engines do have a problem with rear main seal leaking, if you do oil may be acting as a lubricant between the flywheel and the clutch disk, which will cause the clutch to slip. First thought towards solution.

From Sticky: XJ Teck wrightups above
REAR MAIN SEAL REPLACEMENT
http://jeepin.com/features/rearmain/index.asp
Back to top
View user's profile Send private message
Conejo
Member


Joined: 21 Apr 2008
Location: Austin, TX

PostPosted: Tue Apr 22, 2008 7:08 am    Post subject: Reply with quote

It does have the 4.0L motor in it matched to a 5-spd. It has 141K miles on it and has never been overhauled or replaced. I didn't notice any oil leaks, but I haven't had time to really inspect it yet so I'll check the bellhousing today. Thanks for the quick response!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group