Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

AGH! '92 won't start


 
Post new topic   Reply to topic     Forum Index -> YJ Forum
View previous topic :: View next topic  
Author Message
islandhopper
Member


Joined: 05 Jul 2008

PostPosted: Sat Jul 05, 2008 7:23 pm    Post subject: AGH! '92 won't start Reply with quote

Hi, I'm the new guy, have a stock 92 YJ. Been enjoying it for several years until now.
My saga began with noticing my mpg decreasing, so I did the self-diagnosis with the key. My engine was running cold, so I changed the thermostat and flushed the cooling system. Afterward, only the starter clicked. I tried a few times and then the starter stopped doing anything. I replaced the starter with a reman. After replacing the starter, it would turn the engine but no engine start, then the starter started spinning without engaging. I replaced the start relay, now as soon as I put the negative lead back on the battery, the starter energizes without engaging the flywheel. Any ideas? Thanks for any help/expertise. I'd like to do it myself without getting towed to a garage, if possible.
Back to top
View user's profile Send private message
islandhopper
Member


Joined: 05 Jul 2008

PostPosted: Mon Jul 21, 2008 10:19 am    Post subject: Reply with quote

Well, I finally figured it out. It was the ignition switch. I suppose that it was pure coincidence that this switch gave out at the same time I flushed the cooling system. A royal pain to change, but well worth having it running again.
Back to top
View user's profile Send private message
steve0
Banned


Joined: 13 Aug 2008

PostPosted: Thu Aug 14, 2008 12:17 am    Post subject: Reply with quote

I'm new here too ! Glad to see you !
Back to top
View user's profile Send private message Send e-mail
hutchman
Captain Kirk
Captain Kirk


Joined: 07 Feb 2007
Location: Kennewick, WA

PostPosted: Thu Aug 14, 2008 8:50 am    Post subject: Reply with quote

islandhopper wrote:
Well, I finally figured it out. It was the ignition switch. I suppose that it was pure coincidence that this switch gave out at the same time I flushed the cooling system. A royal pain to change, but well worth having it running again.


Glad you figured it out. Those are the worst kind of issues to diagnose......
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> YJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group