Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TF904 Hard Shift From 1st to 2nd


 
Post new topic   Reply to topic     Forum Index -> YJ Forum
View previous topic :: View next topic  
Author Message
originalevil
Member


Joined: 04 Dec 2010
Location: Wilmington, NC area

PostPosted: Sat Dec 04, 2010 6:35 pm    Post subject: TF904 Hard Shift From 1st to 2nd Reply with quote

Hi guys! This is my very first post (but I've read threads, here and there, over the years).

I have a 95 YJ, 2.5L with the TF904, factory gears (3.7x) and 31x10.5x15 tires.

I also have a nasty exhaust manifold leak that I'm taking care of next weekend with a new manifold.

I'm also saving up pennies in case I have to replace the transmission.

The tranny only wants to shift from 1st to 2nd when I'm going at slow speeds or when I back off the gas. It shifts from 2nd to 3rd normally.

I replaced the TPS a few months ago but it didn't change anything... then I got sidetracked with things like a blown head gasket, which included replacing the water pump and radiator, then replacing some bald tires. Most recently, O2 sensor, distributor, plugs, wires, rotor button. Always something!

Anyway, how likely is it that the transmission is shot or is it likely something else that has worn out, maybe affecting the shift point?
Back to top
View user's profile Send private message
originalevil
Member


Joined: 04 Dec 2010
Location: Wilmington, NC area

PostPosted: Tue Dec 18, 2012 5:59 am    Post subject: Reply with quote

Just an update -

I eventually replaced the tranny. It was worn out. Also, the rear axle had to be rebuilt. I put the new manifold on, replaced the water pump and radiator again (don't buy parts of eBay, boys!) and the pulley for the AC. I put on new brake pads and replaced the tires again. Between the end of December 2011 and the beginning of February 2012, I spent just over $3500 on this puppy and it was running like a top.... until I was on the interstate one night and the seal blew on the oil sending unit. When you're doing 75 mph and driving on a dark stretch of road and you suddenly hear "clunk" and lose all your power, it hurts your feelings. I gave the Jeep to my mechanic, since he'd busted as many knuckles on it as I had.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> YJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group