Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

trouble with new engine


 
Post new topic   Reply to topic     Forum Index -> YJ Forum
View previous topic :: View next topic  
Author Message
x-tatik
Member


Joined: 02 Aug 2004
Location: St. louis, MO

PostPosted: Mon Aug 02, 2004 11:04 am    Post subject: trouble with new engine Reply with quote

I recently installed a newly rebuilt 2.5L EFI 4cyl. into my 1990 YJ.

The problem is it dogs it pretty bad going up hills (no power) and also on warm starts it acts as if it is going to die then revs up then almost dies again then levels off.
I've got 100 miles on it...is this because it's not broke in yet? It just doesnt seem right.

Timing is right (not adjustable)....new plugs and wires...checked for vacuum leaks.....all accessories worked fine on old engine.


Any ideas?
_________________
1990 YJ
Back to top
View user's profile Send private message Send e-mail
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Mon Aug 02, 2004 7:41 pm    Post subject: Reply with quote

Sounds like a sensor...my guess would be either TPS or CPS. Or it's possible something is wrong with the ECM itself . If you have access to a ODB reader (I believe that 90 was the last year for ODB and that it went to ODBII in 91), I'd see what it tells you.

Steve
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
Code3TJ
Hacker
Hacker


Joined: 01 Jan 2004
Location: Uzbekistan

PostPosted: Mon Aug 02, 2004 7:45 pm    Post subject: Reply with quote

Also, are you taking it easy on the new engine while you break it in? No long trips, lugging it, etc?
_________________
Nothing to see here.
Back to top
View user's profile Send private message
x-tatik
Member


Joined: 02 Aug 2004
Location: St. louis, MO

PostPosted: Tue Aug 03, 2004 6:43 am    Post subject: Reply with quote

yeah...I am breaking it in exactly how the FSM says.

maybe I should take it to autozone and see if they can pull the codes for me? I'm not getting a CEL but the bulb could be out.
_________________
1990 YJ
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> YJ Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group