Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problem with gauges, none of them work


 
Post new topic   Reply to topic     Forum Index -> Cherokee Forum
View previous topic :: View next topic  
Author Message
fastsxman
Member


Joined: 05 Nov 2004
Location: Blairsville, PA

PostPosted: Fri Nov 05, 2004 2:46 am    Post subject: Problem with gauges, none of them work Reply with quote

I recently took my 98 cherokee mudding and got it stuck, and it sat in water up to the doors in water for about 3 hours, and now none of my gauges work, including speedo, tach, oil, temp, volt, odometer, and fuel. The rest of the vehicle works perfectly, except my airbag light came on, and both airbag fuses were blown, and when i replace them, they blow as soon as i turn on the ignition. No other fuses are blown, and everything else works fine. The gauges themselves are fine and have power. I tried everything, even swapping a friends computer, but that didnt fix it. I figure it's shorted somewhere, but i havnt had the time to check all the wiring. If anyone has had this problem too or knows what could be wrong, i would appreciate it if they got in touch with me.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Fri Nov 05, 2004 2:59 am    Post subject: Reply with quote

When you checked for blown fuses, did you check both fuse panels? There's one on the passenger side kick panel and another under the hood (the Power Control Module). It's also on the passenger side.

When you say they have power, you mean that you have dash lights...right? I don't have my FSM in front of me...but I believe the dash lights are fused in the kick panel, but the gauges themselves are fused in the PCM under the hood.

HTH

Steve
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
fastsxman
Member


Joined: 05 Nov 2004
Location: Blairsville, PA

PostPosted: Fri Nov 05, 2004 3:50 am    Post subject: Reply with quote

I've checked both fuse panels. I was just hoping someone on this forum might have had this problem and could tell me what it is. It's probably just a short somewhere. I'm a student at Wyotech, a car school, and my instructors are also stumped by it. They've looked at it, and suggested the obvious stuff like fuses, but they havnt been able to figure it out. I had about 3 inches of water in the floor too, if that helps. I did the gauge diagnostic, where you press the odometer button, then turn the key on and the gauges start jumpin around, and they all work fine, so i know they get power. It seems like its the signal from the sending units. I'm gonna work on it some more this weekend, so hopefully i will figure it out. Its probably just a short somewhere.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
ThePhantum
Pissed-Off Admin
Pissed-Off Admin


Joined: 23 Jan 2004
Location: I knew it...I'm surrounded by Assholes!

PostPosted: Fri Nov 05, 2004 3:57 am    Post subject: Reply with quote

The first sensor you can check is the speedo sensor on the t-case. Since it was under water for a decent amount of time, it might be shorted out and is taking the other gauges with it. Just a guess.

SInce you're at Wyotech, did you put a DRB on it?
_________________

97 XJ Sport with a bunch of stuff
Quote:
Never argue with idiots, they drag you down to their level and beat you with experience
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
fastsxman
Member


Joined: 05 Nov 2004
Location: Blairsville, PA

PostPosted: Fri Nov 05, 2004 4:07 am    Post subject: Reply with quote

my instructors arent letting me use any diagnostic equipment on it because we havnt gone over it in class yet, which sucks a big one. At first, only the oil gauge stopped working, then the tach and speedo and odometer, then the volt, then the fuel and temp gauge. The fuel and temp gauges were the last to quit. We went over instrumentation and wiring already in school, so i guess this will determine if the 20,000 dollar tution was worth it.

p.s. It's stock now, but after getting stuck, the bitch is getting a lift, some lockers, and some boggers, so i guess its not all bad........
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Fri Nov 05, 2004 4:39 am    Post subject: Reply with quote

I graduated form WyoTech in Blairsville in June. Who's teaching EMS now? And whats your name, I'm not sure if anyone I knew would still be there but its a possibility.
Back to top
View user's profile Send private message Send e-mail
fastsxman
Member


Joined: 05 Nov 2004
Location: Blairsville, PA

PostPosted: Fri Nov 05, 2004 12:48 pm    Post subject: Reply with quote

My names Joe Vest, I started here in July taking ASM. Im in EMS 1 now, my instructors are Fat Mike, John, and Tim. The only people I know who were there when you were there was my room mate Mike Trussell and Pete Keffer.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Fri Nov 05, 2004 7:14 pm    Post subject: Reply with quote

I knew Mike and Pete. I also took ASM first and then automotive, but I started out taking ASM in the old buildings downtown. Mike started the same time I did and took the same stuff I did. Pete started in January so I only knew him thru automotive. Does he still have the blue S10?
Back to top
View user's profile Send private message Send e-mail
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Fri Nov 05, 2004 7:17 pm    Post subject: Reply with quote

Is John by any chance John Russel? and whats Tim's last name?
Back to top
View user's profile Send private message Send e-mail
fastsxman
Member


Joined: 05 Nov 2004
Location: Blairsville, PA

PostPosted: Fri Nov 05, 2004 10:56 pm    Post subject: Reply with quote

I dont remember his last name, he came from drivetrain to ems. Tim is new, u wouldnt know him.
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
fastsxman
Member


Joined: 05 Nov 2004
Location: Blairsville, PA

PostPosted: Fri Nov 05, 2004 10:58 pm    Post subject: Reply with quote

no, pete sold his s10, hes not drivin anything right now. Mike is down in florida right now in BMW school, lucky bastard
Back to top
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger
95sahara
Member


Joined: 08 Oct 2004
Location: Kittanning, PA

PostPosted: Sat Nov 06, 2004 4:48 pm    Post subject: Reply with quote

That is John Russel then, I had him for drivetrain. Tell Pete that you're talking to K-Town, he should remember by that name. Tell John the same thing, he should definately remember me.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group